General discussion

Locked

Permissions and File Sharing

By rlib ·
I have a client with a new installation of windows XP Home. Data files were re-installed from a secondary hard drive. I enabled File & Printer sharing. I set a folder to be shared. I went into the folder and found all files in the folder with the "Read Only Attribute" set. I removed the "Read Only" attribute. When I accessed the file from another computer the file comes up as "Read Only". I went back to the source file and found that the "Read Only" had reset. I could not find any other way of removing the attribute. What can I do?

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by James A Bailey In reply to Permissions and File Shar ...

In the share properties click the permissions tab and click full control for everyone. Then set the NTFS permissions.

Collapse -

by rlib In reply to

Windows XP Home will only allow sharing of files between computers if the file was placed in the Shared Documents folder. The above procedure could not be found.

Collapse -

by w2ktechman In reply to Permissions and File Shar ...

In this day and age, full control for everyone is a bad idea. Best bet is to assign user permissions to the share, and assign the same permissions to the NTFS Security.
It will take a bit more doing, but I would suggest setting permissions per user account that will access it.

Collapse -

by rlib In reply to

Windows XP Home will only allow sharing of files between computers if the file was placed in the Shared Documents folder. The above procedure could not be found.

Collapse -

by InletGroveHS In reply to Permissions and File Shar ...

As said above, adjust the permissions on the share.

You may also need to check the permissions on the individual files. To do so right-click on the file and choose Properties. Choose the Security tab.

In some case you may also have to take "ownership" of the files which can be done through the Security tab by pressing the Advanced button and choosing the Owner tab.

Collapse -

by rlib In reply to

Windows XP Home will only allow sharing of files between computers if the file was placed in the Shared Documents folder. The above procedure could not be found.

Collapse -

by rlib In reply to Permissions and File Shar ...

This question was closed by the author

Back to Windows Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums