Philips GoGear 4GB Error

By gbargar ·
I have a philips gogear 4gb that stuck at the screen and freeze. it will not connect to my computer. nor even come on.. I try to reset it but nothing seem to work. when ever I plug it on any computer, it comes on and say.. OK to disconnect! and that is all. nothing working..

can any boyd help.

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Have you tried this on a different computer?

by OH Smeg In reply to Philips GoGear 4GB Error

It is possible that the USB Port can not supply enough power to drive this unit so try it on a Desktop and then on a USB Port connected directly to the M'Board not through a Fly lead. That means the USB Ports on the back of the case not on the front.

If it works now try attaching a Powered USB Hub and plugging it into that on the computer that it will not work on.

However if it doesn't work on other computers it is possible that the device has died and gone to Silicon Heaven in which case you need to replace it.


Back to Desktop Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums