General discussion

Locked

Ping/DNS OK, No other TCP/IP Connection!

By jed ·
We have a laptop with Windows XP home on it.

I am able to ping other computers reliably from the command line. The machine will alse do DNS lookups (via ping and nslookup).

However, no program seem to be able to connect to another machine.

I have tried to use telnet to connect to 80, 90, 22, 25, 20, etc on our servers with no luck. Telnet takes about 10 seconds and then returns with an "unable to connect" message.

If I REBOOT into safe mode with Networking, THERE IS NO PROBLEM!

I have turned off the firewall, antivirus, etc. Nothing seems to work. I went through and turned off each running service down to the bare minumum, checking the connection after each one. Nothing.

The machine is XP SP2. NAV 2003 is installed, but turned off.

Any ideas?

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by p.j.hutchison In reply to Ping/DNS OK, No other TCP ...

I assume the Telnet service is running other the other machines. By default, telnet does not run.

To connect to shares on other machines you need Client for MS Networks installed and File and Print Sharing installed.

Collapse -

by jed In reply to

Poster rated this answer.

Collapse -

by Blackcurrant In reply to Ping/DNS OK, No other TCP ...

Hi

Are you trying to connect to a domain? Or is it a home network? When you say you can ping computers from the command line are you pinging them by IP address or computername? Your WinXP Home cannot join a domain, but it should be able to browse the network.

Do you have more than one networking protocol installed? If so, try using just one - preferably TCP/IP. Which programs are unable to connect? Can you see the computers in My Network Places?

Good luck

Collapse -

by jed In reply to

I am not trying to connect to any specific service or domain. There are no computers available in My Network, because the machine cannot connect. Here's what I can tell you:

An ipconfig command reveals correct IP settinsg (address, gateway, DNS)

I can do a DNS lookup or ping any internet site (i.e., ping www.yahoo.com works perfectly).

I cannot connect to any sites (internal or external) via IE. Or Firefox. Or FTP. Etc.

I have tried using the telnet command to connect directly to specific servers (LAN and WAN) on several different ports (20,22, 25, 143, 80, etc). This does not work.

If I reboot into SAFE MODE, all of the above works fine. No connecttion problems.

I used 'msconfig' to turn off ALL unnecessary services, startups, virus, firewall, etc, and verified that they were off. Still cannot connect in a normal login session.

I have uninstalled NAV and still get the same problem.

I ran the XP WINSOCK fix and this did not help.
(http://www.apisto.dsl.pipex.com/site1/XPWinsock.htm)

What could cause a machine to have network access in Safe Mode, but not in a normal session?

Collapse -

by BFilmFan In reply to Ping/DNS OK, No other TCP ...

You don't load all the configuration settings or drivers in safe mode.

What I find curious is that you can ping and verify via NSLOOKUP (and that was some excellent troubleshooting to have thought of using that) so that your DNS is apparently functional.

So we have a system, which operates in safe mode and doesn't operate when booted normally. Have you tried to replace the network card driver with the latest one from the maunfacturer's web site? Although, I admit it to be a long shot, it is possible that it could be flaky.

Also, check your settings for the NIC, while in Safe Mode and then check the settings when booted normally. They should be the same. While you did not mention it having checked it, make sure that TCP/IP filtering has not been turned on.

Also, what errors, if any, are you seeing in the event logs?

Please leave more details on the issue as this an interesting one.

Collapse -

by msmith_jr In reply to Ping/DNS OK, No other TCP ...

I had a similar issue with my wife's machine after adding new sound card and some software none of which seemed to have a problem. this went on for a while. just the other day I was sitting at her machine contemplating putting in a new network card but then decided to look things over again. everything appears to fine so just for the heck of it I disabled the network connection and then enabled it guess what it now works except for one other problem if I reboot or shutdown the machine after booting up I have to go into my network places and disable and enable the network connection again.
I was looking at some things on the microsoft knowledge and here on Tech Republic and guess what there was not much to find on either one but here at least I had found similar issue that cause me to sit down at the machine and look at it again.
I still do not know what caused it as there are no irq conflicts or any other problems I can find in the machine.
by the way this is an xp pro machine.

Collapse -

by ryder007 In reply to Ping/DNS OK, No other TCP ...

Try going to Symantecs site and download RNAV2003.exe and RnisUPG.exe. Run these programs this will remove entries left behind in your registry.I think this might fix your problem.

Collapse -

by jed In reply to Ping/DNS OK, No other TCP ...

This question was closed by the author

Back to Windows Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums