Question

Locked

plug and play USB drive disappears, won't come back!

By peadar ·
I've used my usb freecom toughdrive on xp home for months, then the drive letter disappeared. It's not in disk management either. When I reconnect it I get the new hardware balloon and wizard, and the wizard can't find a driver (there wasn't one, it's plug and play), then the usb device shows in computer management as not configured correctly. I've tried Restore, a day at a time, but it makes no difference (a message comes up saying the drive letter is excluded from restore or was removed). Uninstalling from there then reinstalling brings me back into the new hardware Wizard loop.

There's nothing wrong with the disk - it works ok with other computers. I should mention that there is an optional mains connection for the drive, computer seemed to get confused between when it was on mains and when it wasn't.

Any ideas for a fix would be really welcome, i've got all my data on the drive!

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Try this

by Jacky Howe In reply to plug and play USB drive d ...

WinXP by Default turns off USB Root Hubs to Conserve Power causing some devices not to resume correctly after Windows resumes from sleep, hibernation or computer inactivity. In the Device Manager, Universal Serial Bus Controllers, USB Root Hub, Power Management. Uncheck the Allow the computer to turn off this device to save power. Uncheck all boxes on all root hubs. Resart the PC.

Collapse -

drive comes back, then all file info vanishes!

by peadar In reply to Try this

I unchecked the 'allow the computer to turn off this device' box, but the thing that brought it back *temporarily* was using a powered hub. After a while working ok on the powered hub, it started wheezing. At this point I connected the power supply to the drive - the wheezing stopped, and it still worked ok. But next time I booted up - and ever since - it shows as an *unformatted* drive and I'm asked if I want to format it when I try to explore it. All the info about it (name, files) has gone, except for the drive letter.

Disconnecting and reconnecting, rebooting, restore, with/without power adapter - it's still the same. In Disk Management it shows as empty and unformatted RAW; there are no USB problems showing in Device Manager. When I run recovery software on it, it says that critical system structure errors have been found. What really worries me is that my Mac doesn't recognise it now either!!

Collapse -

You

by Jacky Howe In reply to drive comes back, then al ...

havn't supplied enough information for us to go on. Go to the manufacturers site and view the FAQ's. I think this is it.

http://www.freecom.com/ecsupport.asp

If the drive has a power adapter always use it.

Collapse -

done

by peadar In reply to You

Obviously that was the first place I went to. I am also in direct contact with their technical support.

Collapse -

Using the Mains Adapter

by OH Smeg In reply to plug and play USB drive d ...

Wait for the Drive to stabilize and then plug in the USB Plug to the Socket on the M'Board.

What can happen is that some USB Sockets do not supply enough power to support a High Powered USB Device and they can cause the Drive to fail. Similarly if the computer can not recognize the Drive when plugged in after allowing the computer to Boot it's possible that the Socket has been overloaded in the past and is no longer supplying the necessary power to work correctly.

Try a different Socket if you have one available.

Col

Collapse -

Try this USB Port Tester

by Jacky Howe In reply to plug and play USB drive d ...
Back to Hardware Forum
7 total posts (Page 1 of 1)  

Related Forums