Plugging in flash drive - no drive letter provided

By bldsm ·
Each time I plug in my 2GB flash drive the laptop makes a noise to indicate the drive has been found and shows the found hardware ballon but it does not give me a drive letter and I cannot find the drive on any of the allocated drive letters.

Can anyone please help me before I throw the unit out the window in frustration!!!


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Disk Management

by Craig.A In reply to Plugging in flash drive - ...

Right click on 'My Computer' - go to 'Manage' - click on 'Disk Management' under 'Storage' - on the right pane find your flash drive, which probably won't have a drive letter assigned to it, right click on this and go to 'Change drive letter and paths' - change drive letter.

Collapse -

Thank You

by dreyno01 In reply to Disk Management

Thank you, this solution worked!!

Collapse -

Thanks Man!

by tlink211 In reply to Disk Management

I just got a nice new 8Gig drive and managed to screw it right up (it's a gift, I don't question it)....Thanks for the tip, Craig.
Got my drive letter back and everything is warm and fuzzy, now.

Collapse -

You Helped Me too!

by cyclone411 In reply to Disk Management

Thanks for the reminder about using Disk Management. You guidance solved my access problem.

Collapse -

USB driver letter

by lgorod In reply to Disk Management

Thanks a lot. It helps

Collapse -

Will not allow me to rename drive

by Panda1982 In reply to Disk Management

I have attempted to rename the drive as desribed. Unfortunately the CHANGE button is greyed out and will only allow me to select ADD. No letter is currently assigned to the drive and I am unable to access any drop down menu or type in anything.

Has anyone else run into this issue?

Collapse -


by CG IT In reply to Plugging in flash drive - ...

which O/S? if XP or Vista should show that it's installed and viewable when you click the computer icon or computer from the task bar. Also in computer management. You might have to format the drive to use it but should be seen as device with removable media.

Collapse -


by NotSoChiGuy In reply to Plugging in flash drive - ...

...if you are already utilizing the D, E, F, and G mappings, the USB device won't pull a drive letter, depending on the manufacturer.

What I've had to do is to change a drive mapping for something else (like switching the CD-ROM to be the B instead of \)...and then the USB device would load just fine.

I see this less and less frequently, but it still pops up every once in a while.

Collapse -


by Montiger12 In reply to Plugging in flash drive - ...

I have a 16GB Flash(ZIXA) that no longer works in my work pc, but it works on every other pc i've tried to put it in. recently we were put onto Active Directory. Spoke to the admin guy and he has given me rights to access my flash ( I can access other flash drives perfectly, just having trouble with the 16GB )

I've tried all the methods posted so far, but to no avail. Any ideas??


Related Discussions

Related Forums