Port Forwarded Computer not accessible to outside world

By jtbjustin ·
I have set up a web server on a computer in my home network. I am able to access the web server by going to http://localhost or from any other computer on my network by using the local ip of the server. I also want to be able to access the server from computers outside of my home network so I have taken the following steps:
1)set the computer to use a static IP and bound that ip to the MAC in the router settings
2)Forward port 80 to the server in my Linksys WRT300N router
3)Signed up for and configured a account. (Updated by my router)

After performing those steps, I can access my server from internal computers by using my external ip (from although I still cannot access the server externally. I get a connection timed out error. I have disabled all software firewalls on the server.

I am pretty sure I have performed all the required steps, yet this still doesn't seem to work... Any ideas?

Thank you!

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

Have you tried from a computer outside of your LAN?

by ThumbsUp2 In reply to Port Forwarded Computer n ...

If not, try using a computer at the library or somewhere else outside of your home.

Also, have you registered the domain name? If so, it still takes anywhere from 24 to 72 hours for the domain name to propogate throughout the rest of the world. How long ago did you register the domain?

Collapse -


by Churdoo In reply to Port Forwarded Computer n ...

sometimes doesn't allow ddns updates from the router. When you tested from outside, was someone at the home and could verify that the name was indeed resolving the correct IP at the time?
If not, download and install the little updater utility from dyndns and shut off the ddns functionality within the WRT300N.

Also, make sure you don't have remote administration enabled on port 80 on the WRT300N, and lastly, if your site is using SSL, also disable https on the WRT300N.

Collapse -

Dyndns works

by jtbjustin In reply to Dyndns

Thank you for your reply.

The dydns domain works, because I am able to access services hosted on other ports such as ftp.
Although http still doesnt work. I am running apache.

I checked remote admin and SSL was disabled in my router.

Thank you!

Collapse -

DYNDNS is for your domain name

by CG IT In reply to Dyndns works

so if you setup the name servers correctly according to DYNDNS instructions you should be able to get to your web site via that is if your web site on your web server is listening for inbound requests on port 80. Note your A record on DYNDNS needs to be correct [specifies your FQDN as <> or www.<domainname>.com. . Further, make sure you have run the DYNDNS client program and ensure that name resolution is to your public IP address.

If you were using IIS 6.0 or better, I would say to configure host headers to ensure that IIS sends the inbound request to the correct virtual web site.

Apache is another story....

Back to Networks Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums