Powermizer in Mint question

By Slayer_ ·
How do I set it up so that it runs under maximum battery when running on battery, but maximum performance when running on AC. Right now it seems to be stuck on an "Auto" that always seems wrong. I am guessing it is reving up the chip each time Compiz does something. It is causing a very noticable difference in battery life. Windows on "Balanced" or "max battery" gives an average of 1.5 hours of movie watching, on mint, I can let it sit on the desktop and be dead in 20 minutes.

It is an nVidia 7600m

How do I fix this? I have found some things online to change a file, but they are all to set it to max performance, I want it to work more like Windows where it is smart enough to figure it out based on whether or not it is plugged in.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

You can't find the settings, or changing them don't help?

by seanferd In reply to Powermizer in Mint questi ...

Settings should be at Menu → All Applications → Administration → NVIDIA X Server Settings. NVIDIA Powermizer settings are under GPU.

If the settings are stuck or not working properly, are you using the default driver or the proprietary driver?

edit: Oh, and which flavor and version of Mint?

another: And which version of the driver? I'm seeing reports on this from Linux and Windows users, going back a year or two.

Collapse -

latest and latest

by Slayer_ In reply to You can't find the settin ...

It doesn't seem to have options, just a static screen.

look at this screenshot to see what I mean.

-Edit, thats a pretty sad screenshot, I used that screenshot program, maybe its broken?

Collapse -

I have seen these, they are mostly to increase the power

by Slayer_ In reply to Apparently, it is suppose ...

I just want to get it off this auto mode. it doesn't have a "preferred setting" drop down box on my screen.

Collapse -

My only suggestion, then

by seanferd In reply to I have seen these, they a ...

would be to switch the driver release. If you are using the default "open" driver, try the "restricted" (NVIDIA proprietary in-house driver direct from the vendor) driver from NVIDIA, or vice-versa.

Otherwise, you may need to edit modprobe.conf as shown in the post (or perhaps simply edit the string(s) for the field/dropdown box that doesn't show up in your GUI).

All I know is that every time I see this mentioned, people are 61+?h1ng about this function of NVIDIA drivers.

Teh sux. ]:) X-(

edit: pesky emoticons

Collapse -

I am using the restricted drive though

by Slayer_ In reply to My only suggestion, then

Latest version to.

Yeah, I'll go see if I can find that text file, a very unsatisfactory solution though if you have to change the text file and restart your computer each time to change the profile.

Collapse -

Ugh. Indeed

by seanferd In reply to I am using the restricted ...

the NVIDIA powermizer seems like a PITA in a variety of ways.

If you have to do it frequently, perhaps a script?

edit: Say - which desktop environment are you using? Is that Gnome or KDE?

Collapse -

I think its Gnome

by Slayer_ In reply to I am using the restricted ...

I am not certain though, how can I check?

Collapse -

Hm. Usually, I found the name plastered all over everything.

by seanferd In reply to I am using the restricted ...

In app names and on menu's and stuff. Like, your "Start menu" will be a <i>something</i> menu.

Ahhh looks like Gnome is the default in both Mint 9 & 10. (In case you aren't getting an input field where you should, and this is DE-related.)

Maybe <A HREF="">this person</A> could tell you something. Has Powermizer showing in NVIDIA display settings, answering a post on 01 Jan.

Collapse -


by santeewelding In reply to I am using the restricted ...

And drywall, you say.

Related Discussions

Related Forums