General discussion


Primary Drive 1: not found

By appple ·
WHen i boot up my computer.. it wont take me to windows.. it comes up saying " primary drive 1 not found, press F1 to continue, or press f2 to enter setup"

i tried the 'fixmbr' command in winxp recover using the CD.. can anyone tell me what this problem might be? and how i could fix it. .
i have a 120 gig HD, partitioned, 90 gigs - winxp
and 30 gigs unpartitioned, my windows xp , is on DRIVE C:, i formatted the WHOLE 120 gigs...


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

by ozi Eagle In reply to Primary Drive 1: not foun ...


It sounds like your BIOS isn't detecting your hard drive.
Check all your cables that attach to the hard drive for proper seating.
Boot computer and go to BIOS (F2 when asked ).
Check that it detects your primary drive, or get it to auto detect. If this fails your HDD may be shot, or you need to FDISK it before formating. NOTE: Fdisk and format will destroy all data on the HDD.

Collapse -

by dmiles In reply to Primary Drive 1: not foun ...

To troubleshoot this condition boot the computer with a bootable DOS disk. After the computer has booted with the disk try to access drive C: by issuing the standard directory command

DIR C: <enter>

If the C: drive is working and you can see the directory listing then you might be able to make the drive bootable again by issuing the system command which transfers the system files from the floppy drive to the hard drive as follows:

sys a: c: <enter>

The sys file has to be on the floppy disk. If it is not then find a disk that has the file or use another computer to copy the file to the floppy disk. You can also copy the file from the floppy to the hard drive by typing...

copy a:\ c:\ <enter>

...the computer will ask you to verify the operation.

Note: A drive must also have the BOOT partition activated before it can boot properly. This is done using FDISK.exe ( of course you must take precautions doing this since fdisk can make your drive useless if mis-used).

To troubleshoot problems where the hard drive hangs at boot and the computer never responds, turn off the computer and disconnect the hard drive from the ribbon cable that connects it to the motherboard. When you turn the computer back on, you should at least get an error message about the drive being bad, and perhaps go into the BIOS. Once in BIOS you can change the hard drive type to AUTO and after shutting off the computer and reconnecting the hard drive, try again to see if it now works.

Collapse -

by kewlice33 In reply to Primary Drive 1: not foun ...

First thing's first. Check if the system can detect the HDD. If not, troubleshoot the HDD. Try both controllers, try another IDE cable, switch cables, remove all other IDE cables, etc.

After you've formatted the HDD, did you created a single partition on it? HDD which are detected in BIOS but you can't boot on may contain an invalid partition. Format it using XP setup

Hope this helps!

Collapse -

by May_Day In reply to Primary Drive 1: not foun ...

First thing you should do is check your IDE cables, make sure they are connected properly then try boot your system and see if the bios can detect your HD. If unsuccessful, try using a good known IDE cable. You can also try connecting your HD to another computer just to verify if your HD will be detected. Hope it helps.


Collapse -

by OTL In reply to Primary Drive 1: not foun ...

If this is a new HD, did you run FDisk and set the 90 G to primary?

If this was an operational HD, does the bios "see" the HD ? If not sounds like the HD controller card on the HD may be the problem. Several reboots may allow the PC to access the HD, but I would be looking at a new HD.

Collapse -

by bwells47 In reply to Primary Drive 1: not foun ...

What do you have your jumpers set at? I know it sounds wierd, but i have had similiar problems, and change jumpers to cs, and it will most times work, if not working on master or slave. Then boot up, go into bios, and set to auto to detect hard drive. good luck

Collapse -

by irctrix In reply to Primary Drive 1: not foun ...

Try checking to see if it is the IDE slot that is damaged. Unhook all devices and hook just the hard drive up on the secondary IDE. I had that problem with my board and only have use of my secondary IDE slot. If this is the case also invest in an ide expansion card.

Collapse -

try this to fix primary drive 1 not detected

by maybethiswillwork In reply to Primary Drive 1: not foun ...

try going to f2 (bios setup)
check to see the hard drive section does not have an "unknown device" such as the secondary drive. if so, toogle and turn it off. restart and maybe now it will detect the primary drive. worked for me

Related Discussions

Related Forums