Question

  • Creator
    Topic
  • #2268386

    Print Spooler hangs deleting job

    Locked

    by annvv ·

    When printing to a Brother MFC-5840cn, via a USB connection, the print spooler hangs at the point it shows to be deleting the print job. I see no events or error dialogs – it just hangs and nothing will print. Restarting the print spooler service clears the issue, and I have checked permissions to the PRINTERS folder, which appear to be correct for the Local System/SYSTEM account I believe is managing the print spooler service. Note that this is occuring for a workstation user that is configured to NOT have local administration rights, and I need it to work out for that user. Two other users also use the same model printer without local administration rights, and seem to work fine.

All Answers

  • Author
    Replies
    • #2536680

      Clarifications

      by annvv ·

      In reply to Print Spooler hangs deleting job

      Clarifications

    • #2536505

      Quick

      by rob miners ·

      In reply to Print Spooler hangs deleting job

      fix is to add the users to the print operators. They really cant do much damage and they can solve most problems themselves.

    • #2534772

      It is a local printer

      by annvv ·

      In reply to Print Spooler hangs deleting job

      The group you suggest does not exist for a local-only printer. Any other ideas?

      • #2611070

        Try this

        by wishart.jassen ·

        In reply to It is a local printer

        Go to C:\%systemroot%\system32\spool folder

        Open services and stop the spool service
        Delete the print jobs in the spool folder
        restart the spool service

        • #2458550

          print atill wont delete

          by rosscoandsandi ·

          In reply to Try this

          hi i have read numerous fixes on this problem and tried them all. network HP plotter has one print job being deleted then hangs. i stopped the print spool using net stop spool. also tried to stop it using manage services/services/spool stop and start. still nothing. I went to system32/spool/printers and there was no files there to delete. restarted PC and Plotter. still nothing. reinstalled plotter. still nothing. patience is wearing thin. can anyone help?
          cheers
          ross

        • #2566564

          Try this

          by rob miners ·

          In reply to print atill wont delete

          are you pausing the print job before deleting.

          Step 1
          Disconnect the printer from the PC

          Step 2
          Go to the Control Panel and click on Add/Remove Programs. Highlight any Printer Software that is listed here. Select Remove.

          Step 3
          From the Control Panel, click on Printers & Faxes. Right click the printer in question and select Delete

          Step 4
          Look at the Toolbar. Select File, then Server Properties. Look in the Drivers tab. Highlight the printers drivers listed here and click on Remove for each one.

          Step 5
          Reboot the PC. Do NOT reconnect the printer!

          Step 6
          Go to the website of your printer manufacturer. Look for new XP drivers for your model. Download the correct software.

          Step 7
          Run the exe file you just downloaded. It should auto-start the installation program

          Step 8
          The software will tell you when to connect the printer.

          Step 9
          Once the software is installed and the printer connected, try a test page.

        • #2566214

          thanks

          by rosscoandsandi ·

          In reply to Try this

          great detailed description. thourough reinstall.
          cheers
          ross

        • #2566211

          Can I take it that it worked :)

          by rob miners ·

          In reply to thanks

          if it did I am glad to hear that you are up and running. 🙂

        • #2794736

          i have the same problem, total reinstall doesn’t work

          by tkaplan ·

          In reply to Can I take it that it worked :)

          I have a Lexmark X6100 printer connected to a toshiba laptop running Windows Vista with McAfee antivirus software. Every single time i print, the first job prints fine, but then the spooler hangs. The printer works fine on my IBM thinkpad running XP and Norton antivirus, so it is either a Vista issue, a McAfee issue or a Toshiba issue. My guess is Vista.

          I can work around by killing the spooler process, turning the printer off, and rebooting my machine — but this isn’t really a practical long term solution.

          I have downloaded and reinstalled the most recent drivers several times; didn’t help. The most recent Lexmark drivers are digitally signed and are supposed to be designed for Vista.

          I am guessing that there is some type of “job finished” message from the printer that is not making it to the spooler, due to some new security setting in Vista or McAfee. But I have no idea how to track down that setting. I did enable logging on McAfee and nothing is being blocked there.

          CAN ANYONE HELP?

Viewing 2 reply threads