General discussion

Locked

Print Spooler Service Keeps Stopping

By Kareem ·
I have an upgraded Windows 2003 Print Server that has been consistently dropping its print spooler services. I have noticed it only within the past week or so. Here is the event log of the error message:

Event Source: Application Error
Event Category: (100)
Event I 1000
Description:
Faulting application spoolsv.exe, version 5.2.2790.0, faulting module mscvrt.dll version 7.03790.0, fault address 0x000034e36.

I am completely baffled by this error and I have not made any changes since the upgrade to 2003 - only regular Windows updates. Could one of the updates have installed a "bad" version of one of the files mentioned in the error? I need some help quickly. Thanks!!

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by BFilmFan In reply to Print Spooler Service Kee ...

I would try this first:

Start the Registry Editor (RegEdt32.exe).
Locate and remove the following key from the registry:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\ Control\Print\Printers\<Trouble Printer>
Quit the Registry Editor.

And if that doesn't work, try this, expecially if you start seeing exception errors:

Stop the spooler service.
Remove the .SHD and .SPL files from the Spool directory.
Remove any unused or old .TMP file from the Temp directory.
Restart the spooler service.

Hopefully one of those 2 will resolve the issue.

Collapse -

Having the same problem in windows 2003 Server

by smejico In reply to

I have had to utilize the solution of removing the shd and spl files from the spool directory. This will then enable me to be able to start the spooler service back up. Any ideas as to what is the cause of the continued crash of the print spooler.

Collapse -

by cpe07.antiga In reply to

Thank you! Thank you! thank you!

It did.. Thank you .

Collapse -

Thanks!

by MrHowe36 In reply to

Removing the .SHD and .SPL files did the trick, many thanks! I would have been at this for awhile if I didn't find this post :)

Collapse -

removing .tmp solved my problem

by pravin.wankhade In reply to

hey there, removing unused .tmp files from the temp directory has solved my problem, it amazing, I was seating on it for 6 hours now and this at last this resolved my problem. I am not sure what actually happened or whats the root cause, but yea, its done.. thanks BFilmFan.

Collapse -

Printer Spooler Service Keeps Stopping

by ashily24dee In reply to Print Spooler Service Kee ...

Go to Start / Run and type in "services.msc" without quotation marks, then press Enter or click OK.

In the window that opens (Services) look for "Print Spooler" on the right

Right-click "Print Spooler" and select "Properties".

Click on the "Recovery" tab and change all 3 drop-down boxes to "Restart The Service".

Make sure the 2 text boxes underneath say "1" in them.

Click Ok until you are back at the Services window, close it and you're good to go.

Go back into the properties of the "Print Spooler" tab and be sure to click Start to restart the Print Spooler service and it will restart the service immediately.

The Print spooler depends on the Remote Procedure Call (RPC) service. Is this service disabled? Go to services.msc look for RPC. Check state: Automatic

Get more help..............

http://printers.iyogi.com/errors/printer-spooler-service-keep-stopping.html

Hope this information helps you.

Back to Windows Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums