General discussion

Locked

Printer failure

By 99trex ·
Hi,
I have an Epson Stylus C41UX which worked perfectly until it was 30 days out of warranty. The print quality SUDDENLY went very ragged, within a few seconds, and the refused to print at all. I had it serviced fully. The tech reported printer was AOK.
Hooked it up to pc again, running 98se, still no printer. Seems to be a port problem. Printer software wants to use LPT1 all the time. Under printer properties, the port is listed as "EPUSB1: (Unknown local port)", but when trying to print says it wants to use LPT1. Re-installed w98, at tech's suggestion, and printer software, subsequently. Still nothing.
Everything happens as it is supposed to, printer dialogue etc, showing how long to go etc, ink levels, everything, BUT the printer itself remains silent. If it was on a network, you would swear everything was ok. Printer appears in control panel/system as it should. Everything checks ok, but the printer doesn't seem to know this.
Any ideas would be most gratefully accepted.
Thanks in advance.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by HereInOz In reply to Printer failure

Pity you can't hook it up to LPT1!! I have known an Epson Stylus 740 that had something similar to this. Would not work on LPT1 of one particular machine, but was fine on LPT1 of all other machines, and other printers would work on LPT1 of the machine that the Epson refused to work on.

Yet, it was fine on the USB port of the offending machine. Thank heavens it is a dual interface machine.

Same thing - everyone said it was fine, the printer dialog box was fine, just the printing was garbage on LPT1 and OK on the USB.

Maybe try it on another machine and see what happens - that would be my first guess. If it fails to print on another computer, for the price of the printer, put it down to experience, and get another one. If it prints on another computer, but not on the one you have, could be a USB problem on the offending computer.

Alan

Collapse -

by 99trex In reply to Printer failure

Thanks Alan,
It makes you wonder if the problem is "programmed in", doesn't it? I often wondered why the chip thingys on the cartridge. The printer is not far out of waranty. Mmmmm.
One thing is for sure, when I buy a laser printer, it sure as **** won't be an Epson! No way ever again will I buy an Epson product, or a Seiko product,
either.
Now where to? Money does not grow on trees hereabouts.
Neil.

Collapse -

by Techxan In reply to Printer failure

Here is a shot in the dark,

The USB port may be in the wrong state at start up. I did a migration of Compaq equipment and we had this problem. Apparently there are 2 states for the USB port to be. Something like where power is located when the cord is inserted. The cable causes this state to change and the USB port knows that a cord has been inserted. (maybe sonmeone else can help us out here)

Sometimes if the cord is inserted into the USB slot before the BIOS had processed the instructions to activate the USB port, the USB port would activate as unpopulated, and since there is no state change it doesn?t see anything on the port. The solution was rather bizarre but it worked. We were told to boot up the computer and slightly wiggle the cable during boot up, activating something or other. Then we unplugged the USB and re-plugged it back in. Worked like a charm. As a side note, if we simply waited and let the processor run the BIOS completely the problem didn't manifest. Because we were rolling out 30 computers a day, we lined them up and one of us would pass by pluging in devices, hit the boot, since UBD is hot swappable, we did them last. Ocassionally we would put the USB cord in to soon. Due to this reason the problem was random and we had a tough time figuring it out. Finally Compaq sent out 2 REAL geeks, and they figured it out in about 6 hours.

Or you could have a bad USB cord.

Or you might have touched the circuit board on the printer that holds the PnP info in such a way as to short out something.

Of you could just have gotten screwed....

Back to Desktop Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums