General discussion

Locked

printer is missing from my computer

By heather.smith ·
I have xp home, when i start up my computer i have no printers, but when i go to run or comand prompt and type net start spooling...ta da! i have both my printers. i have checked the services prior to useing this command and it says that they are already running and set to auto start. i have even tried to restart them from there but that does not seem to work. this is more of a irritation than anything else but just wondered if they is any way i could make them start with out doing the comand thing?


Comment from heather.smith@... on 04/18/05 :
This printer is my local printer, usb pluged in and the driver is the current version. had this same problem with a older version hp printer that i could not seem to update the driver so bought a new hp printer, to replace it. same problem when i set it up it worked great, but when i restarted it was gone.



Comment from heather.smith@... on 04/18/05 :
also the comand is "net start spooler" but the batch file idea is great! any other sugestions to accually solve the problem would be greatly apreciated.
I might mention this system is conected to a wireless router, then the cable router so that my laptop, located down stairs can access the internet. Since my upgrade to xp we have never been able to set up file shareing or printer service to that laptop, but not a big issue.

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by willcomp In reply to printer is missing from m ...

This is a duplicate to one I posted on your prior question.

May be a stretch, but since print spooler depends on RPC, try suggestion in article below.

http://techrepublic.com.com/5138-10589-5657162.html?tag=search

Hope this helps.

Dalton

Collapse -

by willcomp In reply to

This is not just that RPC is running, but how initiated. Check settings versus article info.

Collapse -

by heather.smith In reply to

Nothing but joy!!!!!!!!!!!!!that little fix did the trick and I got back a bunch on icons on my tray also. so switching the rpc to local did the trick to get the spooler to start on its own. 1200 points thanks so much for your time!!!

Collapse -

by Blackcurrant In reply to printer is missing from m ...

Hi

Another option is to check that the spooler service is starting automatically.

Log in as administrator or with admin priveledges and click Start>Run then type:

services.msc

and click OK

Scroll down the list of services and check that the spooler service is configured to start automatically, and also that if it fails it is configured to restart.

You should also check your event logs to see if there are any events logged(!) concerning the status of your printer and the spooler service.

If you do find any errors and your printer still does not appear when you reboot, reject this answer and post full details of the error.

Good luck

Collapse -

by heather.smith In reply to

spooler did not start auto although it was set to auto

Collapse -

by heather.smith In reply to printer is missing from m ...

there is nothing about printer services in the event log and yes the spooler and rpc & rpl are all set to auto run, and they all say they are running.

Collapse -

by pamcse In reply to printer is missing from m ...

Let me guess... you have XP Service Pack 2 installed. Right? If yes, please post confirmation. Then look at XP OS... not the printer! I think this has to do with the 'extra security' Billy G built into XP.

If XP SP2 not involved, I'll wipe egg from face and go have a beer.

Collapse -

by heather.smith In reply to

go have a beer sorry, see my answer to willcomp, that did the trick nothing but joy!

Collapse -

by heather.smith In reply to printer is missing from m ...

yes xp home sp2 so what did you do??????

Collapse -

by heather.smith In reply to printer is missing from m ...

This question was closed by the author

Back to Desktop Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums