Question

Locked

Printers not automapping on 2003 terminal server

By martin.harris ·
Afternoon All,
I hope someone can help. It might be a quick answer.
We are running a 2003 SBS Server with published printers. The printers map fine when logging onto a XP Workstation. When logging onto our 2003 terminal server the printers do not map. You can map manually and printing works. I had a ton of the 1111 Event ID in system event viewer on the TS. So i have used the TS printer redirection tool to add the missing drivers. No longer get the 1111 errors but still no mapped printers at logon. I have done a ton of reading but i think the issue is down to SBS. Can somebody put me out of my misery : )
Thanks
Martin

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Mapped printers

by Churdoo In reply to Printers not automapping ...

Well the simple answer may be to update the RDP client on the workstations. On the Term Server, in %systemroot%/system32/clients/tsclient is the setup to a potentially newer RDP client. Install that on a test workstation and see if the issue resolves. If not, you'll have to answer some questions.

How are the printers mapped when logging onto a workstation? Are they mapped via a logon script, or did the users simply Connect to the printers they use and are relying on persistent mappings to restore the printer each time they log in?

Are you expecting the TS session to create and use the printers that exist in the user's local printers, or are you expecting the logon to the term server to map directly to network printers via a user logon script?

Collapse -

possible fix for you with MS Knowledgebase article

by TG2 In reply to Printers not automapping ...

http://support.microsoft.com/?kbid=302361

the issue effects 2000, XP, and Windows Servers.

Sometimes they don't map and if you add the registry tweek they might. I've never had an instance where they weren't mapping that wasn't solved by driver updates and this tweek, but you could always be the first.. :)

(PS. that "get the most recent version of Remote Desktop Client idea isn't so great.. there are issues with using it over using the older client... such as older client saved settings in a file that you could copy to any machine, newer one saves in the registry, and so you can't just 'copy' the RDP file or create a shortcut to it, plus for me I've absolutely hated microsoft's pre-authorization concept, where you put your user and pass in, before even connecting to the machine, sure from the server point of view it helps curb invalid attachments for DoS but from a user point of view, I can see the background of the machine I'm connecting to, or set up a logon dialog to see before I type in credentials, and if the info were wrong, like I'd mistyped an ip, I would know it on site)

Collapse -

Clarification

by Churdoo In reply to possible fix for you with ...

I just want to clarify ... the installable RDP client that ships in the W2K3 Server distro, located by default in %systemroot%/system32/clients/tsclient

a) is NOT the new style RDP client which prompts for credentials before making the connection (I'm not crazy about that concept either, but I am getting used to it)

b) connects to printers using non-legacy port names (such as IP, USB, SMB) WITHOUT doing the registry hack.

If I wanted to say "get the latest client," I would have just directed to grab the latest client from windowsupdate optional software

Back to Networks Forum
3 total posts (Page 1 of 1)  

Related Forums