General discussion


Problem in configuring samba on Linus

By pandeysudha80 ·
i am trying to configur samba on
RedHat Linux 9.i can access windows NT machines from Linux but the other way round is not possible...its showing me the Linux machine on network but on opening its giving error message network path not found...though both my Linux n windows machine is in same workgroup.after searching on net i have found out that nmbd & wins.dat is absent in Linux 9.. can anyone help me what should i do...

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by bdavids In reply to Problem in configuring sa ...

Check if samba is running -
/etc/init.d/smb status

Collapse -

by sowens In reply to Problem in configuring sa ...

The Samba service doesn't start by default on Rh 9 so after you have your smb.conf file configured mark the smb service to start automatically. You don't have to reboot to start the service. Just type service smb start. If you can see the Linux server shares from the windows machine then samba is running on the Linux server. Make sure the directories you want to access actually exist on the Linux server.

Collapse -

by Roger In reply to Problem in configuring sa ...

Samba uses a configuration file smb.conf to control the directories a user can have access to. I found that the easiest way to configure samba is to use WebMin to configure the samba server. WebMin can be downloaded free from and when installed on your computer is available as a web server. You can use any web browser pointed to your computer by ip address or by computer name, followed by :10000 to specify the port number. For example if your linux machine's IP address is you would use to access the webmin server. WebMin is initially accessible by using root as the user name and the current root password as the password. You can then change settings on any installed services from within webmin.

Collapse -

by alokchauhan1 In reply to Problem in configuring sa ...

for this u have to start smb service by give the command in bash shell " service smb start " and check the settings by the command " redhat-config-samba " create smb user then u can access this machine by windows machine.

Collapse -

by jackperez In reply to Problem in configuring sa ...

Just because you can see the Linux PC does not mean you can browse it. May I sujest SWAT. SWAT works with your broser so you would need to have Appache working. With SWAT you can twick the samba config file with out knowing to much about it. SWAT works in port 901; so it will look some thing like http://localhost:901/. Also, you need to set your linux directory writes, and the user id and password of you NT box should match the Linux. Good luck!

Collapse -

by BlueNova32 In reply to Problem in configuring sa ...

I am running Windows 2003 Enterprise Server as the Router(3 node)/Gateway to my ISP wireless gateway and Wi-Fi access to other laptops. My Redhat 9.0 server connects to the win2003 router/gateway server through an 8 port switched hub. Both servers are setup as master DNS servers and win2003 is set up as the master domain controller in a forest. WinDNS doesn't seem to have a problem doing dynamic updates to linux just using the samba client. If you did not setup a Network File System(NFS) in Linux, you might have a problem since windows doesn't natively read Ext3 files....But both can read ntfs5, NFS and vfat. Try setting up an NFS or web server in linux. Note, if you do setup the samba server and a single 1-way trust on each of the servers used. You have to set the same password on the kerberos 4/5 server for each connection for it to work with WinNT and linux. Oh, don't forget about kerberos, it is required for the trust to take place. Setup the Key Distribution Center(KDC). For a critique on setting up a two-way transitive trusts between linux and win2000, goto......"
.com/technet/itsolutions/" search for "Active Directory Product Operations Guide Chapter 3". .....This is really a bit much if what you want to do is read files on a linux server from NT. My advice is setup a separate drive/partition on the linux server with vfat as a way to pass files between both servers. The latter will be much easier to do and you'l sleep easier at night. If you don't setup kerberos correctly in both operating systems. You won't be able to login when you reboot linux if the kerberos connection fails to authenticate. Linux will ignore all password attempts. Reinstall, reformat time? I've been there, tried that, heheh.....Good luck!

Collapse -

by BlueNova32 In reply to Problem in configuring sa ...

NT machines....You mean, like NT 5.0, 4.0 or 3.5? If it's Win2000/2003(NT 5.0) setup as an Active Directory Domain Controller, nmbd and wins.dat won't matter. Because, Windows throws out the workgroup name when you upgrade it to a Domain Controller. The server belongs to the Domain in "NT 5.0". You are strictly dealing with computer names, groups, and OU's and you won't need "nmbd and wins.dat". This might help you get around that problem if you are running "NT 5.0/4.0". You might try setting up the Wins server that comes with linux....that might install nmbd and wins.dat....which you might need for "NT 3.5". I hope this helped you and others that come searching for info.

Back to Linux Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums