General discussion

Locked

Problem Installing DVD

By toad ·
I get a report that I need to install a IDE
or bus master driver that comes with the
mother board to enable DMA mode for accessing
DVD-ROM.
I have a Compaq Presario 100c with a Sis 620
Mother board 128Ram and a 433Mhz CPU.

Please Help
Tom

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Problem Installing DVD

by kstam In reply to Problem Installing DVD

Go to "Control Panel" "Systems" "Device Manager" "Direct Memory Access Controller"
Click on "Reserve DMA Buffer" = 64
Ciick on "Restrict DMA Transfer to Memory below" = 16 MB
Do not reboot at this point
Go to "CD ROM Device" to your DVD Player
Click on "DMA"
Reboot and play your DVD.

Best of Luck.

Kai

Collapse -

Problem Installing DVD

by toad In reply to Problem Installing DVD

The question was auto-closed by TechRepublic

Collapse -

Problem Installing DVD

by maxwell edison In reply to Problem Installing DVD

For enabling the DMA setting, simply right click on My Computer icon and then from the drop-down menu, click on the properties option. This will open system properties dialogue box on your computer screen. Now select the hardware tab and then click on the Device Manager button. In the Device Manager window, click on the IDE ATA/ATAPI controllers branch to open it. From corresponding window, double click on the primary IDE channel. This will open the primary IDE channel property box on your computer screen.

In this box, click on the Advanced Settings tab. Here you'll find the details regarding the DMA or Ultra DMA settings mode. If the mode is not set to the DMA or Ultra DMA, then you should select Auto Detection from the Device Type drop-down list and then click OK. Then, close open window and restart PC.

On restarting, return to Device Manager and check again. Here if the current transfer mode setting is still not set to the DMA or Ultra DMA mode, select DMA if available from the Transfer Mode drop down list and click OK. Now once again, close all Windows and restart PC. Repeat the process mentioned above again to check the DMA or Ultra DMA setting installed on your system. This will set your hard disk to the DMA/Ultra DMAmode.

(continued in comments..)

Collapse -

Problem Installing DVD

by maxwell edison In reply to Problem Installing DVD

.
.
However, if you still find your system not set to be DMA or Ultra DMA, then you should first enable the DMA setting in the BIOS. For enabling the DMA setting in the BIOS, simply hit Del, when your system boots up and energy logo is being displayed. Once you are in the CMOS setup utility, open the BIOS feature set to enable the Ultra DMA setting. The above-mentioned process will set the primary channel of the PC to Ultra DMA. However, the other important channel i.e. the secondary channel,on which the CD-ROM is normally installed, remains to be configured for Ultra DMA an setting that is set to the PIO mode as the default setting.

Follow the above-mentioned procedure again and select the secondary channel in the device Manager andchange the mode to DMA. This is an important setting and will significantly boost the PCs performance. By enabling DMA setting on the secondary channel the speed of the CD-ROM though will not increase but by bypassing the load on CPU, the overall performance of the PC will get a significant boost. After enabling this setting on the secondary channel, you'll notice that you won't have to stop working when your CD-ROM is accessing data, which is normally a case in most of the PCs.

Good luck,
Maxwell

Collapse -

Problem Installing DVD

by toad In reply to Problem Installing DVD

The question was auto-closed by TechRepublic

Collapse -

Problem Installing DVD

by toad In reply to Problem Installing DVD

This question was auto closed due to inactivity

Back to Desktop Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums