Our forums are currently in maintenance mode and the ability to post is disabled. We will be back up and running as soon as possible. Thanks for your patience!



Problem: Wireless Laptop cannot see Wired Desktop on Home Network

By jnandi ·
I have a wired desktop PC (HP dx2480) running XP SP3 connected to a LinkSys Wireless 4-port router, and a laptop (Lenovo X61) running XP SP3 connected wireless to the same home network (192.168.0.x). The LinkSys connects by cable to a DSL router for internet access. Both PC and laptop get DHCP IPs from the Linksys (which I have hard-coded - mapped MAC to IP). They are on the same Windows Workgroup "HOME". Both Desktop and Laptop have same Windows User Logins.

My desktop had a virus attack (trojan), which I removed and re-installed XP SP3 (from HP disks). Since then the PC seems to have "network sharing and discovery issues" on the network.

Read a lot of tech-blogs but can't seem to figure out the problem. I'll add some more details on problems, and things I have tried.

- The wired PC CAN ping the laptop, but laptop CANNOT ping PC.
- Both laptop and PC CAN access the internet.
- The laptop and PC COULD NOT see each other on Windows Workgroup, or see shares. This got resolved once I added IPX/SPX/NetBios Protocol on both the wired and wireless NICs on both PC/laptop respectively. NOTE: Before adding this protocol, I double-checked that File-Printer Sharing was enabled on both NICs, Windows Firewall had File-Print Sharing as exclusion. I tried everything including disabling firewall on both, disabling McAfee scanning on both, disabling Firewall on Linksys, but nothing worked.
- The laptop CAN see the NAS (Seagate GoFlexHome - connected by cable to LinkSys) using Seagate Dashboard software and direct IP. The PC CANNOT access the NAS using the Dashboard software but CAN access through direct IP. The NAS is named "goflex_home", which both can discover as \\goflex_home\ from explorer.
- The laptop CAN see ITunes Home Share from a NAS, but the PC CANNOT see any home shares on the NAS (or from the laptop). I even added Home Sharing TCP/UDP ports as exceptions on the Firewall on the PC, but it still doesn't work.
- Some blog checking the node type on IP addresses given by DHCP. The laptop has Node Type "Hybrid", and the PC has "Unknown". I even went to PC regedit.exe and modified the <local machine/currentconfig/services/NetBT/parameters> and Change EnableProxy to 0 or 1 (instead of 2 that was in the PC as default).
- I have used SG TCPOptimizer on both laptop and PC to revert to Windows default

Any ideas? Thanks much in advance.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

The network interface in the desktop may have a duplex mismatch

by robo_dev In reply to Problem: Wireless Laptop ...

Try setting the adapter to 100 mbs full duplex (vs auto).

Many routers have a test screen where you can ping a device...can you ping the PC from the router? Tried plugging into another port on the router and swapping the cable?

When you reinstalled, the NIC drivers were probably an ancient version...I would upgrade to the latest and greatest version.

You should not have to enable IPX/SPX (Novell Server Protocol) or NetBios to get sharing to work.

Disable the firewall and stop the firewall service on both devices when testing.

In Windows firewall, allowing workgroup sharing does not allow ping.
The exclusion to allow Ping is > ICMP Settings>Allow incoming echo request.

If you plug the laptop into an ethernet port on the router, what is the result?

At a high-level, if one device cannot ping the other:

a) layer 1 issue: bad cable, bad NIC, bad router port, adapter duplex issue
b) layer 2 issue, wrong subnet, firewall blocking pings, wrong gateway set

Just to be clear, there is only ONE router and DHCP server on your network, correct?

Why are you doing DHCP reservation for the PCs?

Collapse -

Reponse To Answer

by jnandi In reply to The network interface in ...

@robo_dev - answering your questions

1. can't find a test screen on Linksys admin pages, so couldn't do that.

2. The NIC s/w came with the PC (original HP s/w), and I am presuming that came pre-installed. So, not sure about out-dated NIC software? In any case, I have a RealTek RTL8168C(P) PCI-E Gig Eth Card - so I went and downloaded the latest drivers and installed in any case.

3. Firewall disabled on both PC and laptop, and Windows Firewall/ICS service stopped on both. All tests tried again. PC can ping laptop. Laptop can't ping PC. interestingly net view on laptop shows all 3 entries

Server Name Remark

From PC->Laptop - can ping, can access laptop shares using IP address, but not using the hostname (This is interesting, was not happening earlier). When using hostname it says "Not accessible. No permission". Net View on PC all shows all 3 names as does the laptop.

4. I have tried putting the PC to all 4 ports of the Linksys, including setting the NIC speed to 100FD, same problem. Also, tried some more tests as per @pbpost requests (when laptop is also on wired NIC). Results discussed in reply to @pbpost.

There are 2 routers, one the internal Linksys - giving out DHCP on 192.168.0.x network, which has wireless laptop/wired Desktop, and the DSL Router (which the LinkSys is connected to), which has DHCP enabled and gives Linksys IP on its WAN port (on 192.168.1.x network). the DSL Router gets it's IP through DSL dialop from the service provider. DNS on all NICs is and

I was doing DHCP reservation on Linksys (192.168.0.x network) - just to have same IP numbers when doing testing. Also, atleast in the interim I could get working with mapping IP address linked remote folders, even if hostname based remote folders wasn't working.

Collapse -


by pbpost In reply to Problem: Wireless Laptop ...


Collapse -


by pbpost In reply to Problem: Wireless Laptop ...

As a test, connect a hard wire to the laptop. Repeat:
- Ping to desktop
- Check if laptop and desktop can see each other via Windows Workgroup
- etc

Initial assumption is the wired & wireless may be different VLANs in the limited LinkSys router ability. If everything works via wired and not wireless, the bottleneck becomes clearer.

If so, alternate LinkSys firmware -- Tomato, DD-WRT, OpenWRT, etc -- may give desired VLAN control.

Collapse -

Reponse To Answer

by jnandi In reply to Simplify

@Simplify .... connected laptop wired to the LinkSys now ... so both PC and laptop on wired connections to same subnet 192.168.0.x ... uninstalled IPX/SPX/NetBios on both (since with IPX enabled .. I could atleast see the Windows Network on both, but not ping from laptop->PC) => result .. still can't ping PC from laptop, and can't login into PC shared folders (I can still see the PC name - but that could be from an earlier cached entry) from laptop.The error when accessing the PC shared folders using the cached PC name icon is "\\PC-name is not accessible". When using IP address, it says "cannot find 192.168.0.PC". I can access the internet, and also the NAS, and iTunes HomeShares from my laptop.

From the PC -> laptop, ping works. And the most interesting thing, can also see the laptop's documents shares even with IPX/SPX taken off. I put the laptop back on wireless to double-check, same problem as original - PC can ping laptop, but can't see/access laptop shared folders ... says \\laptop-name is not accessible. No permission". I can, however, now access the folders using IP address. So \\192.168.0.laptop got me to see the shares.

I thought earlier the problem was only in the PC - since it was the one which cannot see the Seagate/NAS share (using the software app/UI) or access any iTunes HomeSharing. The laptop even on wireless has no issues with HomeSharing or seeing the NAS using the software app/UI that came with the NAS). only pinging the PC was a problem.

now it seems, the LinkSys might be a problem too? Since, wired laptop from PC can access document shares using both IP and name. But wireless laptap from PC can access documents shares using IP, but not name.

Hope I haven't confused you all further .... :-(

Collapse -

I think what [pbpost] was getting at

by Charles Bundy In reply to Problem: Wireless Laptop ...

is bypass the linksys router entirely by using a RJ45 crossover cable. I know some of these home routers have a guest setup which firewalls internal lan from untrusted clients. Try the crossover (set static IP on PC/laptop) and see if it is the linksys/DSL routers causing the madness.

Related Discussions

Related Forums