Question

Locked

Problem with Maxtor EXT HDD on Win7

By Cracktower ·
I have read some of the forums on this topic so if this is a repeat please excuse me. I have a Maxtor Touch II 300 Gb EXT. HDD. For the life of me I cannot get it to work on Win7 even though it is recognized. I will break down as much info as possible that I think is relevant.
1)Installed with original disk and updated drivers from the Seagate site for Win7
(express_HD_EN_1_1_127)
2)Rebooted and the One touch menu comes up, the new hardware wizard for Win 7 came up and said it was installed and ready.
It is in the disk management screen. It recognized 279.48 gb (unallocated) and is labeled disk7 with a red arrow pointing down with the following underneath.
Unknown,279.48 GB Not Initialized.
3) I tried to initialize under MBR but it says incorrect function.
4)If it helps, this is the farthest I got with a usb 2.0 cable. It came up with an error (yellow triangle with exclamation point)in the device and printer screen when I used the firewire port. I tried both firewire ports btw. It also says in properties that my drivers are up to date.
5) The Drivers and Maxtor One Touch are recognized as well in the uninstall window.
Sidenote- this drive work flawlessly on both of my xp pro machines in my network but they are 2 stories down and I bought this thing for one purpose only, to backup when needed and then turn off. I don't keep it on all the time ( nor the network stays on 24/7) and though I admit I can use the excercise, I would rather get it to work on this Win 7 machine. I am at a loss on how to get this thing to work. Any help would be welcomed, Thanks in advance.

This conversation is currently closed to new comments.

12 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Disk management in Computer Management

by CG IT In reply to Problem with Maxtor EXT H ...

This: 2)Rebooted and the One touch menu comes up, the new hardware wizard for Win 7 came up and said it was installed and ready.
It is in the disk management screen. It recognized 279.48 gb (unallocated) and is labeled disk7 with a red arrow pointing down with the following underneath.
Unknown,279.48 GB Not Initialized

and this: 3) I tried to initialize under MBR but it says incorrect function


Did you try an initialize the drive in System & Security/Administrative tools/ computer management/disk management?

Collapse -

Yes

by Cracktower In reply to Disk management in Comput ...

I got all the info from #2 and #3 from the disk management screen. I downloaded the ISO image from another forum post concerning this same model, but the ISO image is for a Touch 3 device and it looks like it is the same drivers, a little leary of installing Touch 3 software for a Touch 2 drive...

Collapse -

try running the Maxtor software in XP compatibility mode

by CG IT In reply to Problem with Maxtor EXT H ...

I've often run into the problem of applications being able to run on Vista but they don't on Windows 7 until you run the program in XP compatibility mode.

Here's some posts about problems with the Maxtor OneTouch and Windows 7. One users Sam687 used an XP machine to unlock the Maxtor.

http://social.answers.microsoft.com/Forums/en-US/w7hardware/thread/b09b2ca9-224d-4d2c-bc4a-b30a18de54f8

I've run into some encryption problems with Windows 7 where Windows 7 doesn't recognize the encryption method eg. 40 bit/56bit/128bit/256 bit keys but this was on encrypted VPN with PINS and passwords. The problem might be that your encrypting the drive using the Maxtor security settings and Windows 7 doesn't recognize it.

Collapse -

Way ahead of ya

by Cracktower In reply to try running the Maxtor so ...

I already tried it on xp3 and xp2. I guess I will have to wait until Tuesday to contact Seagate being Seagate will probably be closed due to MLK Day. When I click on the one touch button the main menu shows up, but when I click on anything it seems that it clicks through one window really fast then it goes to select a drive screen with no drive visible....
Thanks anywho.... :)

Collapse -

I don't think you understand the directions above

by OH Smeg In reply to Way ahead of ya

It was suggested to try this Drive in XP Mode on your Windows 7 Computer.

Some of the versions of Windows 7 support what is called XP Mode which allows you to run XP Software on your 7 OS as a Virtual Machine.

This is to prevent new buyers demanding to get XP installed on their new computers and allow M$ to have a smother transition to 7 for Business.

Of course you need a CPU and M'Board which supports XP Mode as well as a version of 7 that has this enabled. generally Speaking the Pro, Enterprise and above support XP Mode.

The full directions for XP Mode and Virtual PC are available here from the M$ Web Site

http://www.microsoft.com/windows/virtual-pc/

Col

Collapse -

HUH?

by Cracktower In reply to I don't think you underst ...

I right clicked on the Maxtor One Touch Drive Shortcut and hit properties/compatability...xp3/...xp2 after it didn't work....and so on. I am the only admin on this cpu and yes I have admin rights enabled. This doesn't work. I actually did install the Maxtor Touch 3 disk as previously mentioned after I cleaned out all Touch 2 stuff in the uninstall menu. If I am missing something please let me know, I have installed this software with the new drivers, without the new drivers, installed the old drivers only to install the new drivers on top of it. Installed the new drivers only instead of installing the old drivers. Tried without the old software being it says on the Seagate site that all the options from the touch 2 software will not be available on Win7. I have always uninstalled and rebooted every time I did a change, not the way I wanted to spend my entire weekend. Did you see my screenshot of my desktop showing everything says it's ok? If there is a way to install it under xp from the start,instead of installing under Win7, then switching to xp mode, please let me know. Thanks in advance....

Collapse -

XP Mode in Windows 7 is a virtual machine running XP

by CG IT In reply to HUH?

and the processor and motherboard has to support hardware assisted virtualization. Microsoft is Hyper V and AMD virtualization support is AMD V. Intel has theirs as well.

Most companies that don't want to shell out hundreds of thousands of dollars on new peripheral equipment [when the old works perfectly well thank you very much] that is Windows 7 compatible can use XP Mode on Windows 7. Allows legacy hardware to run.

I've used it once. It's ok. It's interesting feature, but well Virtual stuff to me is good for huge server farms and data centers. But for the SMB/medium sized business and consumers ? what's the point except the cool factor?

Collapse -

Naw Oh Smeg Compatibility mode not XP Mode

by CG IT In reply to I don't think you underst ...

but thats a really good suggestion. Didn't think of it.

From what little research I did on the Maxtor OneTouch, it seems as though the Maxtor security settings interfer with having Windows 7 identify the drive so it comes up as unknown.

After that, about the only thing I can say is that there is a lot of equipment people own that just isn't going to work with Windows 7 even if that equipment worked with Vista.

I run 64 bit and often run into the problem of non "made-for" Windows 7 devices just not working. The sometimes work using compatibility mode. Example eReader for eBooks. It say Vista compatible but you have to run it in XP compatibility mode to get it to work on Windows 7. For hardware...even with Vista drivers they sometimes don't work.

Collapse -

Me Bad

by OH Smeg In reply to Naw Oh Smeg Compatibilit ...

At the moment the shops have only been open for about 30 minutes and I already feel as if I've got a full days work under my belt today.

Well 5.5 hours at least.

But above I must have misread your directions to Run XP Mode and then attempt to launch the Maxtor Drive in Compatibility Mode. When I was testing 7, I had some Vista hardware that had to be initialized like that under 7 before it would work properly.

May help out here but then again it may not.

I pulled the testing plug on 7 last week it's OK for domestic use but still a little too quirky for Business as far as I'm concerned at the moment.

Col

Back to Windows Forum
12 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums