General discussion

Locked

Problem with my NIC eth0 card

By miotti ·
Hello you guys... I have Debian Woody installed in my pc and, a few days ago I upgraded my kernel from 2.2 to 2.4.22. Everything prior the upgrade worked just fine; now somehow I cannot get my ethernet card to work. The driver installed in the new kernel is the correct one, the device is recognised, the module is loaded - I run the 'ifconfig' command by itself and I only get the 'lo' information - if I try the same with eth0 I get that it is configured properly but when I start the service 'ifconfig eth0 up' I get an error message saying that the device is busy! What can that be? How can I overcome this problem? Thank you all in advance....

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by peeyush_maurya In reply to Problem with my NIC eth0 ...

hey,

Take out ur NIC ,start ur computer ,shutdown, plug NIC in different PCI slot ..and start computer


If u have onboard ..then ...login and type the following command and paste the result here...
dmesg | grep eth


Regards
Peeyush
http://www.peeyush.tk
http://geocities.com/peeyush_maurya/

Collapse -

by peeyush_maurya In reply to

Windows XP might be having correct driver for it..

Collapse -

by miotti In reply to Problem with my NIC eth0 ...

Thank you Peeyush!

I shall give that a try. You have no idea how I appreciate this! I almost went nuts because of that...

Thanks again,....

Collapse -

by miotti In reply to Problem with my NIC eth0 ...

Another thing I should have mentioned is that - I also use WinXP with that same pc (just by changing the HardDrive) and I get a perfect running network....no problem whatsoever with the NIC!

Collapse -

by dee.estrada In reply to Problem with my NIC eth0 ...

try to unload the NIC card then run kudzu..

Collapse -

by Amit sharma In reply to Problem with my NIC eth0 ...

You may face this problem while you are restarting your machine from Windows xp & booting the linux. Power OFF your machine for few minutes & then boot directly to linux. This occurs because windows xp/linux after direct restart from one OS to another doesnt allow other OS to awake the ethernet card.

If this didnt work around...
Check out for all the IRQs (interrupts), isnt there any clash of IRQs on ur box.

If answers given above produced you the result its good. Otherwise feed me back.

Back to Linux Forum
6 total posts (Page 1 of 1)  

Related Forums