Question

Locked

Problem with power supply?

By iStatik ·
GIGABYTE GA-EP45-UD3P LGA 775 Intel P45 ATX
I purchased this mother board and 4 gigs of ram and a core quad and i hook everything up and i go to turn the power supply on and it doesnt come on. I have tried to hook three different power supplies up to the motherboard with no avail. I have tried two cords and even tried all power supplies with both cords and in different sockets.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Try a bench test

by Jacky Howe In reply to Problem with power supply ...

Carefully remove everything from the Motherboard. Remove the Motherboard and put it on an anti-static mat on a bench. Remove the Power Supply if it is a known working good one to test with. Remove the Heatsink and give it a good clean. Remove the CPU and reseat it. Reinstall the Heatsink remembering to use CPU grease. Reseat the RAM and test with one stick at a time. Connect a hard drive and the Video Card. Connect the Power supply to the Motherboard. You can use a flat blade Screwdriver to short the Power pins on the Motherboard if you haven't got a spare switch. Connect the Monitor and turn it on and see what happens. If it stars up add one Device at a time to test it. If it doesn't RMA it under warranty.

EdiT: also check to see where the CMOS jumper is as it maybe set to clear CMOS.

Collapse -

Check your CMOS jumper

by Slayer_ In reply to Problem with power supply ...

Lots of times you will buy them with the jumper missing, or on the clear setting. If not, try setting it to the clear setting, try and boot, then move it back to the normal setting and try again... this is how I brought my mobo to life, had to do this like 6 times before it would remain working. Been solid as a rock since :).

Collapse -

Well Gigabyte M'Boards generally come with the CMOS Jumper set to run

by OH Smeg In reply to Problem with power supply ...

So the BIOS Clear shouldn't be an option unless someone has messed with the M'Board.

Here however what Make & Model is the RAM that you have fitted and where is it installed.

The EP45 M'Board use Dual Chanel RAM and if you use the wrong type of RAM or fit it to the wrong sockets this can stop the M'Board from starting.

Also with the 775 Intel CPU's it is possible to incorrectly fit them to the CPU Socket which can have the same effect. So you need to remove the Heatsink & Fan unlock the CPU and remove it. Carefully check the CPU Socket for any Bent Pins and if there are none refit the CPU so that the 2 Plastic Bars lock into the CPU Cutouts.

If there are any bent pins in the CPU Socket buy a new M'Board as the unit will not be likely to work and this is not covered by the warranty.

If it is still not working and you have a Known Good Power Supply remove all of the RAM and try turning on again. If you do not hear a series of Beeps from the M'Board remove it from the case and lay it flat on either an Anti static Pad on a bench or clean white paper connect a Power Supply to it and a Video Card and Monitor and try turning on again. If it works now carefully check the case for the correct positioning of the M'Board Standoff's and move as necessary then refit the M'Board.

If it doesn't work disconnect the Power Supply Video Card and Monitor turn the M'Board over and look for any burn marks on the back of the M'Board where a incorrectly placed standoff has shorted out.

If there are any burn marks you'll need to replace the M'Board.

Post back if you need any more help.

Col

Back to Hardware Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums