Question

Locked

Problem with RDC

By jhbobo ·
I have a remote win2003 server, which i lost RDC connection to it.
I have used portqry to verified port 3389 is not listensing anymore.

Is there any way that i can reset the port so it will listen again or remotely restart the server?

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Are you sure remote desktop protocol hasn't been disabled on the server?

by ManiacMan In reply to Problem with RDC

Also, could your firewall be blocking TCP port 3389?

Also, you don't need portqry to check for open ports. You can use the standard telnet built into Windows to check.

The syntax is:

C>telnet servername 3389

If the port is listening, you'll get a blank screen with a blinking cursor. If the port is blocked or unavailable, you'll get a timeout error.

We need more information about where this remote server is. Is it across a static WAN link, such a T1, or is it over a VPN connection using the internet and two routers? Are you allowing TCP port 3389 to pass through your firewalls? If it's a remote network, are you doing port forwarding to allow TCP port 3389 traffic to be directed towards your server's private IP address?

Again, we need more info about your network and how you're doing the RDP.

Thanks.

Collapse -

re:

by jhbobo In reply to Are you sure remote deskt ...

I was able to RDC into this server just a few days ago, and later on i was not able to RDC it again.
I have use the terminal server manager to clear out the remote session and it didn't help.
I have tried the telnet command, and receive error message
"connecting to servername could not open connection to the host, on port 3389:connect failed:
We are using WAN connection and there is no firewall enable between each remote site.
here is the error message i received from RDC
"The client could not connect to the remote computer
remote connections might not be enabled or the computer might be too busy to accept new connections. It is also possible that network problems are preventing your connection."

Hope this is enough information.

Thanks for the help

Collapse -

Shot in the dark

by tintoman In reply to re:

If you were able to RDP and now you are not it follows that configuration changes have occurred on your server either volutarily or not, I would suggest it's likely that microsoft/windows updates or possibly your internet security software live update has reset the firewall to block access.

Collapse -

re

by jhbobo In reply to Shot in the dark

i thought so.
anyway, i was wondering if i can restart the server remotely, that might resolved the problem.
I could have asked someone on site to fix the problem, but this is our file server and there is no local IT on this site.

Collapse -

Worst case scenario, you can run a VBScript to remotely reboot the server

by ManiacMan In reply to re

Here is the code. Simply replace servername in the first line within the double quotes (do not remove the quotes) with the Netbios name of the server in question:

strComputer = "servername"
Set objWMIService = GetObject("winmgmts:" _
& "{impersonationLevel=impersonate,(Shutdown)}!\\" & _
strComputer & "\root\cimv2")

Set colOperatingSystems = objWMIService.ExecQuery _
("Select * from Win32_OperatingSystem")

For Each objOperatingSystem in colOperatingSystems
objOperatingSystem.Reboot()
Next

Save this code into a file called reboot.vbs onto your hard drive and run it from the command prompt using the following syntax (be sure to specify the path if you're not in that current directory where the script resides:

C>cscript reboot.vbs

If this doesn't work, then I don't know what will.

You can also run the reboot command from the command prompt to target the remote server. Run the reboot /? command from a DOS prompt to see the syntax of the command.

Collapse -

re

by jhbobo In reply to Worst case scenario, you ...

it is working, i have restart the server remotely and now i can resume the rdc connection.
thanks a lot

Collapse -

Awesome. Sounds like some process was hanging up the server

by ManiacMan In reply to re

I'm glad it worked out for you.

Back to Networks Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums