Problem with Remote Desktop Connection on Server 2003

By gman478 ·
I just accepted a new position and one of my first tasks is to determine why remote desktop connection isn't allowing connections on a server running Server 2003. The server is acting as a domain controller as well as a file server. If I use remote desktop connection on the server I can access a workstation. But if I try to connect to the server via the workstation I get an error that says "The computer can't connect to the remote computer."

I have tried connecting with both the IP and name of the server and it doesn't seem to matter. I have looked settings to make sure it will allow a connection and it will. What are some other things I can try to correct this problem?

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Make sure you user is allowed to access the server

by SynapsE_z In reply to Problem with Remote Deskt ...

I have Remote desktop setup at my office. You must make sure the user you are trying to connect to the server with is allowed to connect. Make sure the user is part of the Remote Desktop Users group. Also make sure allow access is checked on the dial-in tab in AD. I don't know if you control access though remote access policy or not but it would be good to check there as well. Let me know if this help.

Collapse -

A little more information

by gman478 In reply to Make sure you user is all ...

Let me give you a little more information regarding the problem. I was told that they used to be able to connect to this server using remote desktop. The two people, besides me, that are trying to connect have domain admin rights so the user permissions should be in there by default. I asked if they made any changes that they could remember right before it quit working and they said they couldn?t remember any and they aren?t exactly sure when it quit working.

I looked at the services and it appears they are all running. I made sure Windows Firewall was disabled and there is no other software or hardware firewall on the server itself. I installed the latest version of Remote Desktop on the server and the client PC and I still cannot connect. If I use remote desktop from the server to my pc it works fine, just not the other way around.

Thanks in advance for any help.

Collapse -

in my experience

by david.wallis In reply to A little more information

dont listen to end users. Ive had hundreds telling me things used to work, when in actually fact they never did!

users wanting to Remote Desktop to the server HAVE to be in the Remote Desktop Users group on the server

also they must have the Dial In allowed in Active Directory

do both of those things and let me know how you get on...

also check the firewall :) make sure its allowing remote desktop

Collapse -

Make sure certificates are correct

by SynapsE_z In reply to Problem with Remote Deskt ...

I remember not being able to connect once when I was able to before. Ended up being an old certificate that needed to be deleted so that it could download the current one. Check your event log and see if there are any errors related to certificates. You can find the reg key here:


Export the whole thing then delete everything in there. When you try to connect to Remote Desktop it will download the new certificate. Let me know if it works.

Collapse -

Checked and triple checked

by gman478 In reply to Make sure certificates ar ...

OK, I did what many of you recommended and none worked. I made sure the users where added in properly into the proper groups and the active directory settings were correct. I went and tried the reg key deletion and this didn't work either. What are some other suggestions. I have never seen anything like this before.

Thanks for you all of your help and future suggestions.

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums