General discussion

Locked

Problem with XP Pro and Mapped Network Drives

By j2per ·
I have several businesses that I have configured on a "workgroup" network. I have then mapped those systems to a network drive letter on the server - for this example let use "M" as the mapped drive letter. These systems then use a universal integrator that connects them to this server to access the data.

The problem is that when the units are turned on at the beginning of the day, the "M" drive is not "connected" - it is there, but not available. So, my integrator software will not start.

I have contacted several network administrators, Microsoft, DELL and Linksys and no one has an answer on how I can get the network drive letter to initialize at startup every time!

Can anyone help? Thanks

Jeffrey

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Did you specify the mapping to be persistent?

by Why Me Worry? In reply to Problem with XP Pro and M ...

Also, since you are in a workgroup environment and not an Active Directory domain, the server will need to have all of the users account of the remote PC users setup on it. This is the downside of setting up a system in a workgroup instead of a domain. Every server will need to contain an exact copy of all of the user accounts on every PC to grant permissions to resources on that specific server. Why don't you set them up in a domain environment insead? It will be easier from the administration standpoint, but you also need to understand how AD works and how to setup domain controllers, DNS, DHCP, global catalogues, etc.

I hope I answered your question, but feel free to elaborate if I missed something. :-)

Collapse -

Thanks

by j2per In reply to Did you specify the mappi ...

Thank you so much for getting back to me. I appreciate the fact that this network should truly be in a domain environment, but I am learning the in's and out's of doing that. In the mean time, I am trying to resolve this simple issue...or what I thought was simple!

I have an "everyone" user on the server, that has full access - are you suggesting that I add the users from every workstation? I am not sure I understand what you mean by "persistent" - Thanks

Collapse -

More info. .

by bkinsey In reply to Problem with XP Pro and M ...

Do a "net use" command. What does the status for that drive letter show on first startup? How does it show up in Windows Explorer, as normal, grayed out, or with a red 'X'?

Did you map the drive through explorer, via command line, or what? And what user context is it mapping under? That user has to exist, have the same password, and have access rights to the folder on the server.

Collapse -

More Info

by j2per In reply to More info. .

Thank you so much for getting back to me. Here is some added info
I did a "net use" and the "M" drive shows up as "disconnected" - When I go into My Computer, the "M" drive letter is there and looks perfectly normal (not grayed out or x'd) - When I single click on it the details display and say "disconnected" - if I double click the icon, the "M" directory opens and then all is OK.

I mapped the drive through "My Network Places", then "View Workgroup computers", I found the server, the shared drive and then mapped as "M"

The server has an "everyone" user that has full access

Does this help troubleshoot the problem?

Collapse -

Yep. . .

by bkinsey In reply to More Info

Yes, this is a known issue. Here's what's happening: the server has an idle connection time-out setting. By default it's 15 minutes, I think. Any time that connection has no traffic for more than that time period, the server closes it. On the client, it will show as disconnected, but due to the persistent mapping, Windows still knows about it, so it shows up in your drives list. If you double-click or open it in some way, it re-establishes a connection, and all is well.

The problem is that your application doesn't know that. It wants a connected drive, and when it can't find one, it fails to do whatever it is it's supposed to do.

So, two possible solutions: one is that you can adjust the idle connection timeout on the server so that connections aren't dropped overnight. You can do that from a command line, but MS recommends editing the registry. The key is HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
There's an autodisconnect value there; probably set to f (it's a hexadecimal value). Change that to ffffffff, which is 65,535 minutes. Sessions then won't expire overnight.

Alternate solution is on the client end. Persistent mapped drives (mapped with the 'reconnect at logon' option) maintain mappings, but not connections. So when you startup in the morning, it just keeps track of "hey, there's a drive on server whatever that we're calling M:" - it doesn't actually connect to the server at that point.

Your option here is not to use persistent mappings, but to do 'net use m: server\share /persistent:no' instead. Probably in a login script, if you use those. That way, the share is not only mapped, but a connection is opened, and would be availble for your app to use.

Either way should work. The auto-disconnect on the server is probably easier, but the net use is a little more foolproof, as the auto-disconnect timer will be reset if the server ever reboots, meaning your connections will probably fail first time afterwards. . .

Collapse -

Persistent Mapping

by j2per In reply to Yep. . .

Hello there and thanks for the reply. Can you tell me more about persistent mapping. I tried editing the registry and changing the connection timeout, but my network drive ("M") is still coming in as disconnected. UGH! I do not fully understand the 'net use m:server\share /persistent:no" command....

Can you explain further? Do I create a file in notepad? where do I place this file? Thanks -

Collapse -

More. . .

by bkinsey In reply to Persistent Mapping

Just to be sure it's clear, the registry change to increase the timeout setting is a SERVER change, not a change to your local registry. You'll also need to re-boot the server for it to take effect.

For the client/net use approach, I'll need some more info about your setup to tell you in detail how to proceed. The command itself is simple enough - it's just an operating system command that allows you to connect a network drive. You can type it from a command line and it will work. The 'server' and 'share' need to be replaced with whatever the server name and share name of your M drive are supposed to be.

Although you can type it from a command prompt (which will help you see what it's doing, if nothing else), that's not your long-term solution, unless you want to do that every day before running your app. That's where the login script would be useful - it would run the net use command at every login, ensuring that the drive was connected. And yes, the script is really no more than a text file which you can create with Notepad.

What to do with it is where I can't answer you without knowing your network setup. Is this a peer to peer network or a domain? Active Directory or otherwise, if it's domain? For a true login script, you'll need a domain setup, with a domain controller that authenticates user logins, and keeps track of things like login scripts. I you don't have that in place already, the login script approach isn't really what you want.

In that case, you can do the same thing locally; just create a batch file with the net use command and stick it in the startup folder in the start menu. That will do basically the same thing, although it's not nearly as manageable if you're talking about large numbers of computers. . . .

Collapse -

verify net use command?

by j2per In reply to More. . .

Hello there BKinsey...can you help me one mor time? First, I must say THANK YOU...your advise is great and I would love to learn more from you!

OK, I have created a notepad file with the following line in it....can you verify that this is correct? I added this file to the startup but the network drive letter is still "disconnected" at startup. They enduser needs to double click it before it becomes "connected".

net use M:\persistent:yes

Is this correct?

Thanks

Collapse -

Not exactly. . .

by bkinsey In reply to verify net use command?

A few things. Number one, you don't want persistent set to 'yes', you want it set to 'no' so the script re-maps the drive at every logon. Also, the flag before the persistent option needs to be a forward slash, not a backward one.

Most important, though, you're missing the sharename you want to map to. You're basically telling it to use the drive letter M:, but not what to use it for. Syntax is net use [device] [share] /[options], where device is the drive letter you want to use and share is the network resource you want to map to that drive letter.

Here's an example for one of our scripts:
net use i: \\ch-storage-1\images /persistent:no

Substitute your own drive letter and the path to the network share you want to map, and it should work. . . .

Collapse -

Kind of a dirty fix, but.

by TonytheTiger In reply to Problem with XP Pro and M ...

Make a batch file that "net use"s M: then runs a dir or something innocuous.

Put a shortcut to this batch file in the "\Documents and Settings\All Users\Start Menu\Programs\Startup" directory.

Back to IT Employment Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums