Question

Locked

Problems with Intel PRO/Wireless 2200BG, DLink DI524 and XP SP3 connection?

By evin.hill ·
I've been battling a wireless connectivity problem and I'm not sure which of the three devices are the cause. The setup is an IBM/Lenovo Thinkpad T42 with an Intel PRO/Wireless 2200BG card running Windows XP SP3 and a D-Link DI-524 wireless router. The problem is the T42 will sometimes connect using WPA/2 if I unplug the router and my cable modem and bring them back up. It will then connect, but after a day it will drop the connection and then it gets stuck doing the connecting/renewing ip shuffle and never connects. If I change to open or WEP, it will connect with no problems. I have another laptop a Dell D610 with XP SP3 and it has no problem using WPA/2 or any other form of wireless. So I'm looking for some advice or if anyone else has experienced this with a similar setup and any solutions you may have come across.

I've tried doing the netsh commands I found on the net regarding this particular. I've tried re-installing the firmware on the router. The only thing I can think of to do next is a re-install of Windows, but this seems a bit much. I did notice that at times when I would uninstall the drivers and re-install, the MAC address would not show up in the properties box until I would run a WinSOCK fix program.

Any advice is appreciated.

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

you're not alone

by bsdxlr8r In reply to Problems with Intel PRO/W ...

at lenovo downloads page for one of the pre-requisites (hotkeys) for using the latest driver for this interface; see "*1" conditioner next to listing of T42 thinkpad under details of hotkeys. This explains that latest download supports Vista only. i just tried archival (earlier) version of hotkeys and still must give control to my Intel PRO Wireless 2200BG to my Windows XP SP3. after windows connects to my linksys wrt54g, i then have access connections connect. access connections complains that wrong driver or protocol installed - (though windows can use it fine).

in summary; i see three possible solutions to this problem.

1) stick to allowing windows to control your 2200BG.
2) find archival releases for all parts of the requisite chain for functionality with access connections.
3) upgrade to Vista (not a viable solution on this hardware - even with the max 2GB ram)

- all myriad of guessing, frustration, confusion and misdirection is all that is available regarding this problem. One common thread is that these apps add too much fat anyway. intel and lenovo broke the Windows XP / T42 support within their "updates".

Back to Desktop Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums