Question

Locked

Problems with USB drives

By Lantoc ·
Recently, whenever I try to plug in any type of USB Mass Storage Device into my XP Home computer windows gives me a balloon saying that the device has malfunctioned. Clicking on the balloon yields a list of all used and unused USB ports with the device listed as Unrecognized. All other USB devices work fine, the WiFi card, a joystick, they all work. I've tried every port all with the same results. I have tried reinstalling XP to no avail, so it probably isn't a driver problem. I also don't think it is a hardware problem, not only because the other USB devices work, but because I have booted Linux off of a Live CD and it was able to mount the drives. I'm now at a loss as to what it might be. Any ideas?

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Driver

by bsmith523 In reply to Problems with USB drives

It could still be a driver problem. If you reinstalled windows over the old windows directory it does not erase all the files that were there. I don't believe the driver for USB mass storage devices is installed by default so the old driver is still probably there and windows is trying to access it when you connect the device. Try reinstalling the USB mass storage driver and see what happens.

Collapse -

Re: Driver

by Lantoc In reply to Driver

I actualy tried that before reinstalling Windows, it didnt work. Also, when I did reinstall it was a clean install after a hard format.

Collapse -

me too!

by dj_vella In reply to Re: Driver

recently (last week?), i began receiving that same annoying yellow pop up. i use SonicStage to transfer music to a Sony Mini-disc player. if i plug just the USB cable into my machine, i start getting the pop up warning you mention. i plug it to the MD player and it doesn't "see" it. sometimes it will connect, but the device only responds for a short time.

in the past, a windows update has caused this problem, and sony issued a patch to fix it. i haven't seen anything released this time around. not surprising though since sony has been phasing their mini-disc out.

anyway, if you find a cure for this, i'm all ears.

john

Collapse -

I wish I could...

by Lantoc In reply to me too!

... No one any ware seems to have a solution. Most people rule out driver problems, device problems, and hardware problems and then are stuck. What else could be wrong?

Collapse -

more info...

by dj_vella In reply to I wish I could...

i get the annoying pop up any time i connect the cable. My minidisc player does not have to be connected to the cable.

mystery.

john

Collapse -

Check your system, hardware first

by intrepi In reply to Problems with USB drives

Go to settings/control panel/system/hardware/device manager and take a look to see if you have any hardware issues.
You may need a mass storage controller from Via or Nvidia or other provider. The last thing I'd do is download, buy and install Registry Mechanic as this software will show you all the errors in your registry and I'm dead sure you will have more than a few. This program is specifically designed for Windows as I'm also certain you would not have the same problem if you try another OS, like linux.
I'm certain this is a Windows problem related to the registry which may have so many errors that it's become corrupted. I strongly advise you to buy this software as it's not expensive and it WILL make your PC run a lot faster. Check it out online and try before you buy but I do highly recommend it.

Collapse -

Too many USB devices, maybe...

by bob.west In reply to Check your system, hardwa ...

Get a powered USB hub and attach the device to it.

Collapse -

to many usb devices problem

by technojunkie In reply to Too many USB devices, may ...

I am having a similiar problem on two identical computer.

I have 7 devices plugged into the usb ports. and when I plug a 8th one in it come up with a device unknown, if I unplug one of the other devices. the new device will become reconized.

the system needs all the 7 device to be plugged in at one time.

1) camera,
2) signature pad,
3) printer,
4) externally powered hub,
5) security key 1
6) security key 2
7) security key 3

the systems actually have 7 usb ports on it 2 in the front and 5 in the back.

but if I try to plug anything else in to the system, I get the error.

the machine's appear to be identical and they are doing the same thing. so I hesitate to condem a reg problem. they are owned by the same company but is two seperate location managed by two seperate it departments.

Collapse -

Have you considered the load on the M'Boards & Power Supplies?

by OH Smeg In reply to to many usb devices probl ...

A USB Port is supposed to provide 500 Milli amps of Current at 5 V DC. With 7 USB Ports in use that is 3.5 Amps.

So look at the ability of the M'Board to actually produce that much power and the PS in the computer to deliver it.

I would be betting that the computer can not deliver that type of power so you need to use some High Quality Powered USB Hubs to overcome the shortcomings of the design.

Col

Collapse -

USB Mass storage Device

by ananeo In reply to Problems with USB drives

After researching the OS, device and drivers I found the problem to be the device is requiring more power than the usb port can provide, I actually had to purchase a y-cable that goes from both ports on my pc to the device in order to stop the errors. You can go into device manager and delete the usb drivers and when it reinstalls, you can tell it to not give you the error message.

Back to Storage Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums