Question

  • Creator
    Topic
  • #2211736

    Program starts sometimes, won’t start others. No pattern that I can see…

    Locked

    by blueeagle79 ·

    I have a program I’ve been trying to run on my machine at home. I hesitated to ask this question here, since it’s just a game and not anything work related, but this one really has me puzzled and I was hoping someone would have some insight on this peculiar circumstance.

    This program requires a two-stage start; launch the “Launcher,” and it checks for updates, and then gives you the option to start the “Main” program. If you attempt to start the “Main” program manually, it tells you to use Launcher.

    So, I try to run the Launcher; it gives me an error, and quits. I try to run as Admin. I try with different compatibility settings. I turn off compatibility settings. Eventually, it works; usually through simply “Run as Admin” in the right-click menu, even AFTER I’ve tried that before, in all the various compatibility settings.

    So, the Launcher runs, checks for updates, then tries to launch the Main program; and now the Main program fails, and it closes. Now, when I try to run the Launcher again, it repeats it’s prior behavior, and I spend ten minutes screwing with the settings before it randomly decides that it’s going to work, always on a combination of settings that failed not 5 minutes prior.

    Now, seeing how the two programs have like a 5% success rate individually, it’s nearly impossible to get them both to run simultaneously. So, I WAS able to create a shortcut to the Main program, so that it will run without the Launcher. I still have to get the Launcher to run periodically to check for program updates, but updates are infrequent, so I’ll very rarely end up trying to connect with an outdated version of the program.

    What really gets me is the lack of a pattern in all of this; settings that work one time will not work 10 minutes later, and settings that failed will suddenly cause success 5 minutes afterwards.

    In addition, my girlfriend is able to run the same program on her laptop, (Windows 7 Home, or Home Premium,) without a single issue what so ever. We installed from the same .exe, and hers runs without a hitch every single time, while mine behaves just as described on both my desktop, (specs below,) and in a test run on my laptop. (Lenovo X61, Core Duo 1.8, 3g ram.)

    Any ideas would be appreciated, either as to how to fix it, or just about why it might be happening. Also any information about people who have had similar issues might help.

    I’m not even incredibly worried about finding a solution to this, so much as I’m just frustrated by the seeming lack of a pattern to the errors. I CAN get it to work, with a couple of minutes of trial and error each time, but I’d like to know what’s causing the error, more from an educational standpoint than anything else.

    Thanks in advance for all your help.

    Adam

    System Specs – Intel Core Duo 2.2, 3g RAM, Nvidia-based 9500GT graphics, Windows 7 Pro.

All Answers

  • Author
    Replies
    • #2814266

      Clarifications

      by blueeagle79 ·

      In reply to Program starts sometimes, won’t start others. No pattern that I can see…

      Clarifications

    • #3026341

      Yet one critical piece of information…

      by smartacew0lf ·

      In reply to Program starts sometimes, won’t start others. No pattern that I can see…

      Is missing. The name of the game? This one sounds like one that uses the Sony launcher. I forget which it was I had a similar experience with, but the final solution for it was to wait damn near all night for the game to update from the server. Seems there was nothing to indicate that was what was happening at the time either. Next morning all was fine though. Oh, I also went to the NIC properties and unticked the fields “Allow the system to turn these devices off when not in use” before leaving it for the night.

      • #3026250

        Update server

        by blueeagle79 ·

        In reply to Yet one critical piece of information…

        No, it updates fine; it has a display bar and everything for that, and that, (when I can get it to launch,) runs right along and either downloads updates at a good clip, or tells me that I’m up-to-date.

        Network is a wired connection on my desktop, so I doubt it’s a power-saving issue….

    • #3026324

      I’ll take a stab

      by mr_m_sween ·

      In reply to Program starts sometimes, won’t start others. No pattern that I can see…

      Is it Aion?

      My guess is that launcher is triggering a service or process that isnt always triggering. When the main program launches it looks for the running service or process and finding none, errors out.

      • #3026251

        Process?

        by blueeagle79 ·

        In reply to I’ll take a stab

        If it’s looking for a process that isn’t running, why does alternating between attempting to run it in Admin mode and Regular mode seem to get it to run?

        I’ve managed to make it run fairly consistently by right clicking, and hitting “Run as Admin.” This gives me an error, so I attempt to run it via double-click, with standard privileges, which also errors.

        Repeat those 2 steps anywhere between 5 and 30 times, and the game will eventually launch; sometimes in Admin mode, sometimes not.

        Oh, and the game is Knight Online. Fairly fun, simple, and free. (you get what you pay for, right?) I only play it because it plays well over a satellite internet connection, which is the only thing available to me.

        I doubt it’s a problem with the network; the error seems to occur instantly, well before a signal would’ve had time to ping the servers and get back. With a ping time of 750 to 1000, it’s fairly noticeable. Also, my girlfriend runs it no problem sitting not 4 feet away from me.

        Thanks again for the help.

        • #3026246

          To run Knight Online using Windows Vista: (or 7)

          by seanferd ·

          In reply to Process?

          1. Go to the Directory that you have installed Knight Online in (default C:\Program
          Files\Knight Online)
          2. Find the following .exe files: Launcher.exe and KnightOnline.exe. Right click each
          application and select Properties from the drop down…
          3. Select the Compatibility tab.
          4. Select “Run this program in compatibility mode for: Windows XP (Service Pack 2)”
          5. Also select the box “Run this program as an administrator.”
          6. Select OK.

          ————–

          Can I run Knight Online if I’m using Vista?

          To run Knight Online using Windows Vista:
          While Microsoft’s Vista is not officially supported by Knight Online, it is possible to run the game if you have this operating system. To do so please follow the steps below:

          * Make sure you’ve upgraded to the latest service pack from Microsoft. You can get
          most updates to your operating system at the official site here
          http: //www.microsoft.com/windows/default.aspx?icid=winvan
          * Make sure to install the game when running under your administrator
          account.
          * Once installed, right click on the Knight Online Launcher.
          * Click on ?run the game as administrator?

          If after following these steps you are unable to run the game successfully, please visit the official forums here.
          —————

          You never said what the error was, either. 😉

        • #3026114

          Compatibility Mode

          by blueeagle79 ·

          In reply to To run Knight Online using Windows Vista: (or 7)

          I’ve tried compatibility mode; it doesn’t seem to have a noticeable effect. The programs still run/launch with about the same frequency whether I am in compatibility mode for XP SP2, SP3, or Vista.

          Here’s the output of a crash of the “Main” program.
          ___________________

          Problem signature:
          Problem Event Name: APPCRASH
          Application Name: KnightOnLine.exe
          Application Version: 2.3.11.1718
          Application Timestamp: 4bfb61d3
          Fault Module Name: StackHash_0a9e
          Fault Module Version: 0.0.0.0
          Fault Module Timestamp: 00000000
          Exception Code: c0000005
          Exception Offset: 02df1ac8
          OS Version: 6.1.7600.2.0.0.256.48
          Locale ID: 1033
          Additional Information 1: 0a9e
          Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
          Additional Information 3: 0a9e
          Additional Information 4: 0a9e372d3b4ad19135b953a78882e789
          ——————–

          Heres the error report from the “Update” or “Launcher” program. Incidentally, the first time I double-clicked it, it ran fine. I closed it out, waited a minute, then double-clicked it again, and it brought up the error for me. How accommodating of it…..

          Problem signature:
          Problem Event Name: APPCRASH
          Application Name: Launcher.exe_Launcher 응용 프로그램
          Application Version: 1.0.0.1
          Application Timestamp: 48fd7fcb
          Fault Module Name: StackHash_0a9e
          Fault Module Version: 0.0.0.0
          Fault Module Timestamp: 00000000
          Exception Code: c0000005
          Exception Offset: 027e1ac8
          OS Version: 6.1.7600.2.0.0.256.48
          Locale ID: 1033
          Additional Information 1: 0a9e
          Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
          Additional Information 3: 0a9e
          Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

        • #3026019

          What’s with the Korean “Applications” there?

          by seanferd ·

          In reply to Compatibility Mode

          At any rate, as the applications crash, I suggest sending that output to the developers. They may be able to tell you what is causing this, or fix a bug on their end.

          Obviously, there is some difference in hardware or software between the 2 Win 7 installations to which you refer. There isn’t much anyone can do for you online, as this would involve some detailed debugging.

          If you are into this sort of thing, you can profile the running apps and crashes with tools like ProcMon and WinDBG.
          http://technet.microsoft.com/en-us/sysinternals/default.aspx

          You can make sure of the obvious things, like having all drivers up-to-date, and Flash up to date as well. (It is Flash-based, isn’t it?)

    • #3026249

      So have you tried an un/re-install?(nt)

      by nexs ·

      In reply to Program starts sometimes, won’t start others. No pattern that I can see…

      .

      • #3026113

        Un/Re-Install?

        by blueeagle79 ·

        In reply to So have you tried an un/re-install?(nt)

        5 or 6 of them, on both my desktop and my laptop, using different source files, (one of which successfully installed to my girlfriends laptop with no issues.)

        Also attempted running installer as Admin or not, alternately.

        One thing I just realized I haven’t tried yet….running the install executable in compatibility mode….any thoughts as to whether that might work?

        • #3026064

          Anything is worth a try

          by nexs ·

          In reply to Un/Re-Install?

          Could also maybe try connecting to the network using a different NIC.

          maybe grab a USB wireless adapter and see if it’s flaky network?

          Just an idea.

Viewing 3 reply threads