General discussion

Locked

Program won't use 100% CPU

By Subdude ·
I have a PC that will not use 100% of its own cpu. I have a giant excell spreadsheet (over 20MB) and when I cause it to re-calculate itself(F9) or ask it to "save", it will only use about 20-30% of the cpu max (this according to task manager). I have documented this with the spreadsheet being the only application open. How can I unleash the power of my PC so that I don't have to wait forever for this thing?
thank you in advance for any help you may be able to give me.

This conversation is currently closed to new comments.

14 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by TheChas In reply to Program won't use 100% CP ...

Please reject this answer and add a comment to your question with some more information.

Which version of Windows?

Which version of Office?

What type and speed CPU you have?

How much RAM?

How much free hard drive space?

In order to provide a reasonable answer, we need to know more about your system.
Different versions of Windows and Office may require different solutions.

Chas

Collapse -

by Subdude In reply to

Which version of Windows? 2000

Which version of Office? 2000

What type and speed CPU you have? p3, 1 gig, I think

How much RAM? 1 gig

How much free hard drive space? plenty - about 100 GB

Collapse -

by DKlippert In reply to Program won't use 100% CP ...

Excel is influenced by logic, not brute strength (:')

Here are some links that may point the way to faster calcs.

http://tinyurl.com/2v8k7

http://tinyurl.com/29cev

Collapse -

by Subdude In reply to

Good links

Collapse -

by jschein In reply to Program won't use 100% CP ...

another factor is your Virus Scan... Disable it.. then open that spread sheet... Should open in about 3-5 seconds. If you are confident about xls documents, you can exclude that type of file in the settings of your virus scan.

Collapse -

by Subdude In reply to

Virus scan is a plausible cause

Collapse -

by w2ktechman In reply to Program won't use 100% CP ...

First, it doesnt/shouldnt need to use all 100% of your resources. The slowest part of your system is not your processor, in this case it is probably your HDD. You can defragment often to keep it as fast as possible, but I do not think that your proc should utilize 100% cpu time opening an excel file, if it did I would think that something was wrong with office/ or windows.

Collapse -

by Subdude In reply to

Not the HDD. When you hit F9, the thing is thinking, not writing. When you do a save it thinks (as it recalculates) and THEN writes. The writing part goes pretty fast actually. Didn't address the problem as described.

Collapse -

by csmith In reply to Program won't use 100% CP ...

I hate to even get into this subject, but here goes.
Undocumented Windows.
The problem you have is not a hardware problem. It is a software problem.
Applications running under any Microsoft Operating System except MS-DOS have a priority number.
The Compiler sets the value at a default midrange value, and most programmers do not know about this "feature" except the programmers who write OSs.
This means that there are "services" in the OS (Win2K) that have higher priority than Excel.
If a service is "hooked" (Extra subroutine called) by an inefficient program, or an inefficient program is assigned a higher priority, a lot of time is wasted.
Antivirus is one, and it was mentioned.
So, you will have to check all of the services that Win2K is running, not just the applications.
(You already checked for time piggy applications, by running a test, with Excel as the only application running.)
Next, if the problem is not in the OS services, the problem can be in the interaction problems between the Memory Manager, the Cache Manager, and Virtual Memory.
Improper placement of the TEMP Directory will aggravate the problem.

Microsoft has not documented this problem, but that is not a problem. Tools are available to check the system.
One free set is called Cacheman, and is a download from www.cnet.com (Cnet is the parent of TechRepublic.)
The Disk Cache for a regular PC should be twice the Cache RAM installed on the hard drive. Your HD probably has 8 Meg cache installed so 16Meg Max and 4 Meg Min would be the normal settings. (You can look this number up in the specifications of the hard drive. They are listed on the manufacturer's website.)
The optimum place for both the TEMP Directory and Virtual Memory, is on a separate hard drive on a separate controller. The closer you get to the Win directory, the worse.
This surprises most people, but it come from the way multithreading is implemented.
For your hardware configuration, the location of TEMP and VM is no

Collapse -

by csmith In reply to

t very important, unless you have placed them in a small partition, along with Win2K.
In your case, I would start troubleshooting with the Cache, then next check the services running.
There is also a way to force a program to be the only thread running, besides raising the priority, but really serious programming is required. (Not a practical solution.)
Regards, Chris
(Comment was necessary because of lack of space.)

Back to Desktop Forum
14 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums