General discussion


protocol problem, using Mac to access a shared printer on a Windows 7 PC

By marktompsett ·
I have a printer on a Windows 7 PC and set the printer to be shared and given it a sensible share name (ie without any spaces, underscores, or other awkward characters) and another PC also running Windows 7 is able to print to it successfully.
However when I try to add the shared printer to a Macintosh (which I have been able to use to access shared printers on a Windows XP PC, so there seems to be no problem with the Mac connecting to the network itself) running Snow Leopard, I added the printer apparently successfully but whenever the Mac tries to print something to it I get the error "Unable to reserve port: Address family not supported by protocol family".
I have tried searching the web for this error message but not been able to find anything that illuminated the problem, let alone indicated a possible solution.

The printer concerned is a Kodak ESP 3250, and I have used the Kodak driver on the Macintosh to connect to it (although I have tried other drivers and got exactly the same error, so I don't think it is a driver issue).

I also doubt that it is anything to do with the type of network (LAN or wireless) but in this case the Mac is connecting wirelessly, but I guess I could use a LAN cable instead and disconnect the wireless, just to see if it makes any difference at all.

I am baffled.
Can anyone suggest a solution?

PS Apologies if I have posted this in the wrong place - I am new here.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Related Discussions

Related Forums