General discussion

Locked

Proxy Access Problem

By mteal ·
I'm having a problem with accessing anonymous ftp sites on an NT 4 network running MS Proxy Server 2.0. The network also runs Trend InterScan on the proxy server to scan incomming an doutgoing traffic.

The problem occurs as follows.

1) If users try to left-click a file on an ftp site the error "12013 - The user name was not allowed" comes up. However, the users have not been asked for a username and I have confirmed that the site accepts
ftp connections.

2) If users try to right-click the same file on the same site, the error "Internet Explorer was not able to open this site" appears (as if the ftp link is invalid, which it is not).

3) If I use an FTP client (or the free client in Windows NT), the site allows me to connect and asks for a username. I enter the username anonymous and no password is asked for. However, if I then type any command, such as cd or pwd, it simply hangs there.

4) As an administrator, I have been given the "full access" permission on the windsock proxy. If I then set up IE and the FTP client to not use the proxy, the FTP client does the same thing, however, I can left click the file to open it or right-click it to choose save.

Any and all help much appreciated!

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Proxy Access Problem

by asep_hendriana In reply to Proxy Access Problem

Try to isolate the problem:
- Disable Trend InterScan
- Use other FTP Server software such as Serv-U

Collapse -

Proxy Access Problem

by mteal In reply to Proxy Access Problem

Good idea with both of those suggestions.

I disabled the interscan services, but still had the same problems.

I've tried three ftp clients - serv-u (as suggested), Cute FTP and Leech FTP, as well as the original WS FTP and the inbuilt client with NT. Unfortunately I still get the same result, even when I disable the proxy settings.

Collapse -

Proxy Access Problem

by Mikel~T In reply to Proxy Access Problem

I ran into a similar problem, and here is what I had to do. I created a user on the NT server called anonymous, assigned a password for the account, and then in IIS I entered the username (anonymous) and the password I assigned the username into the FTP, Gopher, & WWW service, under the anonymous connection fields.

I would also go to microsoft's knowledge database, and look up the following articles also.

Q163651 - concerning passive ftp
Q177311 - concerning winsock + ftp and IE 4

try the first resolution I listed above, but Microsoft's Knowledge database is your best resource otherwise.

I hope this shines some light on the situation.

Mike

Collapse -

Proxy Access Problem

by mteal In reply to Proxy Access Problem

Mike,

Thank you very much for your suggestions.

I added in a user called anonymous on the proxy server. (This is a domain environment, but I added it as a local user). I then added it as the username to use for anonymous access. I added this through the properties of the WWW service. I didn't see anywhere under each protocol to add the account. Did I miss something?

Unfortunately adding the account didn't make any difference.

I looked at those two articles on Technet. The first onewas already implemented (the range of ports for passive FTP).

In terms of the second, I tried the workarounds suggested in IE and had no luck. In terms of the wininet.dll file, the version with IE5 is later than that so I don't think that is the problem.

Now to the success I've had! Because of your suggestion I set up the FTP protocol to use PASV transfer mode and it worked! Is there another way or something else I need to do to allow passive mode as an option for FTP sites or will I needit set on a site by site basis?

Collapse -

Proxy Access Problem

by jvohs In reply to Proxy Access Problem

The second answer about passive and active ftp is probably correct. I've seen that before.

Collapse -

Proxy Access Problem

by mteal In reply to Proxy Access Problem

I was able to connect if I changed one of the FTP clients to use PASV mode. However, when I made the change via Internet Options / Advanced, IE still couldn't access this site.

The other thing I found on TechNet was an article saying that to use passive FTp on the web proxy, you need to make a change to the registry. I've done this, and restarted the server, but still have no luck!

So, I can access this file two ways - if I set the FTP client to PASV mode or if I bypass the web proxy and use the winsock proxy (works with both passive and non-passive - found that via technet).

However, the IS manager really wants us to be able to access this site via IE, using the web proxy.

Collapse -

Proxy Access Problem

by mteal In reply to Proxy Access Problem

This question was closed by the author

Back to Windows Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums