Question

Locked

Proxy Configuration in Fedora 7

By CharlieSpencer ·
I've installed Fedora 7 on a VMware virtual machine running under XP SP 2. I'm unsuccessful accessing the internet with Firefox 2.0.0.3.

I've configured the proxy settings as follows:

In Fedora, I clicked on System, Preferences, Internet and Network, Network Proxy.

For HTTP Proxy and Secure HTTP Proxy, I entered the name of our proxy server (www-proxy.domain.com) and the port (not 8080, but the correct port number for our configuration). I used the same entries I use successfully for FF and IE on my XP system.

In Details, I entered my Windows domain username in domain\username format.

These are the only changes I've made since the installation.

I cannot access the Internet with Firefox. Regardless of the site I try to reach, I get a "Connection has timed out" error.

I installed Fedora from an F-7-i386-DVD.iso file. When I attempt to run Applications / Add/Remove Software, it appears the application is looking at the Internet instead of the .iso. I get at Retrieving Software Information window with a progress bar that doesn't got past 20% or so. Eventually I get the error "Unable to retrieve software information. This could be caused by not having a network connection available." I remember from my previous attempts with FC5 that the Add/Remove wants to look at an Internet repository for software. (I was hoping F7 would look to the installation source before hitting the net, but apparently this isn't the case.) I suspect the proxy settings are also causing the problem with Add/Remove.

So, any guesses what I've done wrong with the proxy settings? Lacking that, any ideas how I can point Add/Remove back to the ISO so I can install the software that's there?

Thanks.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Blatent bump to move this up on the Questions list.

by CharlieSpencer In reply to Proxy Configuration in Fe ...

Since I was dumb enough to post it on a Friday afternoon.

Collapse -

Proxy configuration

by paulo In reply to Proxy Configuration in Fe ...

Hello- I am having problems with the proxy client as well; I am not really sure if it is working or not. But, I did get around the two problems you describe. For the Firefox problem, I configured the application to use my proxy server by going into the browser's Preferences window (Edit | Preferences). I configured the proxy setting by clicking on the connection settings button on the advanced tab. As to the problem with yum or the software update/ install applications, I added a line 'proxy=http://proxyservername:port
' to the bottom of the /etc/yum.conf file.

I am still trying to see why these apps do not make use of the 'global' proxy server setting.

Collapse -

workaround-

by paulo In reply to Proxy Configuration in Fe ...

After some searching, I came across the following workaround.

I added the following line to the end of the /home/myhomedir/.bash_profile file:

# The Web proxy server used by this account
http_proxy="http://servername:port"
export http_proxy

It should work after you log in again; at least it did for me.

one link to info I found is here:http://www.linuxquestions.org/questions/showthread.php?t=125114


Paul

Back to Networks Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums