Question

Locked

PS/2 and all USB ports are not working

By weehee ·
I have a eMachine T1840 (XP SP2) and after a power supply failure, the PS/2 and all USB ports stopped working even after replacing the power supply. It just keep giving me the "Power Surge on hub port" error message.

Device Manager can see the USB hubs and the USB mouse can draw power from it (light on optical mouse), but it's not working. The PS/2 mouse cannot be detected by the system at all.

What options do I have besides replacing the computer entirely? Would it work if I buy a PCI USB card?

Thank you!

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Have you entered CMOS during startup?

by Absolutely In reply to PS/2 and all USB ports ar ...

Power supply problems tend to reset BIOS to
default/failsafe/minimal configurations. Try
re-enabling those devices in BIOS.

Collapse -

PS/2 ok, USB ports still dead

by weehee In reply to Have you entered CMOS dur ...

Thanks for the tip. I checked the BIOS and the USB ports are already enabled but they still doesn't work. Windows still gives me the "Power Surge on Hub Port" message.

Please help.

Collapse -

Same problem

by brafferton In reply to PS/2 ok, USB ports still ...

Same computer, similar circumstances.
Power supply died, replaced, now any USB device instantly locks up the computer
Tried the BIOS, reloaded XP Pro and SP2: No joy.
No idea what to do next.

Collapse -

Re: Same problem

by weehee In reply to Same problem

I tried what you have done with no avail, so I ended up buying a PCI USB card.

All the USB ports that came with the machine still don't work, but at least I can still use my USB devices thru ports on the PCI card.

Depending on how soon you plan to replace your PC, you may want to just buy a new one altogether and pop in the old hard drive to move data to new machine.

Back to Networks Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums