General discussion

Locked

RAID 133 BOOT PROBLEMS

By quintar51 ·
I hope you can help me with this.

I created an RAID 0 Array using the Raid 133 card.
Both HDD got detected before I created the Array.

I then installed windows 2000, and used the drivers for the RAID card that
I saved on a floppy.

Windows 2000 installed OK, and I do see the RAID card installed correctly in the Device Manager.

My only problem is that I can?t boot.
It scans for a boot record in the A drive, CD Drive, and SCSI drive, and doesn?t find one.

I went into the BIOS on the RAID card, and tried setting the first HDD to BOOT. That didn?t work.
I also tried changing it to HDD0, but same thing.

The weird thing, is that if I put a bootable CD, ie. Windows 2000 CD, but I won?t start the installation, it?ll eventually
Boot normally, and I can log into my O/S. Same goes if I have a floppy in there (bootable or not).

How can I fix this problem??

Thanks,

Ronen

This conversation is currently closed to new comments.

17 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by TheChas In reply to RAID 133 BOOT PROBLEMS

I might be wrong, but for some RAID configurations, the boot drive CANNOT be part of the RAID array.

Here's the issue.
Your BIOS / DOS / Windows cannot access the RAID array until the RAID driver is loaded.
While they all can see the hard drives, they cannot read the drive to see the OS files and load Windows.

What I cannot explain is how you are able to start Windows with a floppy in the drive.

Chas

Collapse -

by quintar51 In reply to

I double checked the manual for this RAID card, and it is set up correctly (for RAID 0). Both my HDD are primary masters and are plugged into the card. NOTHING is plugged into the IDE Controller on the Mobo except the CD Drive. A friend of mine had this same card working on his machine. I'll see if he ran into anything like this.

Collapse -

by Joseph Moore In reply to RAID 133 BOOT PROBLEMS

Man, this is screaming weird BIOS to me.
>I have a floppy in there (bootable or not)
So, if you have even a blank floppy, just as long as the system spins up the floppy, cannot find anything bootable on it, you are THEN able to boot from the disk array?
That is the weirdest thing I have heard in a while!
I would flash the BIOS, get the most recent update from your mobo manufacturer, and update it. Also, get an update for the array controller card and update that also. Actually, do that first, update the array card.

Collapse -

by quintar51 In reply to

Regarding the floppy, it actually has the drivers for the RAID card, and now that I researched it more, it is bootable.
It can only boot using that. If I try any other floppy, then it doesn't boot. When I installed Windows 2000 and pressed F6 to install the RAID driver, I did browse to the floppy, and it did find the driver. I wonder if it didn't copy it for whatever reason.. but then again, I can see the card in Device Manager... SO TO CLEAR THINGS UP, IT CAN BOOT USING ONLY THE FLOPPY THAT CONTAINS THE RAID DRIVERS. Sorry about the misunderstanding. For now, it's a short-term solution, although clearly not a practical one.

Collapse -

by quintar51 In reply to RAID 133 BOOT PROBLEMS

UPDATE - I got in touch with the manufacturer of the card and they suggested I use the FixBoot command in Win2k. If that doesn't work, they suggested repairing the installation. I'll try it and post the results.

Collapse -

by Kinetechs In reply to RAID 133 BOOT PROBLEMS

Hi all,
I'd try disabling the IDE controller(s) on the MB...all of them...and try a boot. If it works then the problem is that the onboard IDE is the prefered boot and not the PCI RAID card. Check the BIOS to see if there is an option for boot order that says PCI Card or something similiar. If not, then try to enable the secendary MB controller only and try another boot. You can also removing all hard drive references in the boot order. This way, the onboard BIOS will not try a HD boot and maybe the BIOS on the card can take over.

The strange behavior when you put a bootable Windows CD in the drive is because the CD actually booted. It displays a message telling you to hit any key to boot from the CD but in reality, it already started booting from it. If no key is pressed, the boot code on the CD will check other devices for boot code and it'll eventually hit your RAID controller.

Good luck,
Sean

Collapse -

by quintar51 In reply to

Hi Sean, thanks for the help. I did check the BIOS on my mobo and tried setting to boot order all to 'disabled' but that didn't work. My only options for a boot device are a floppy, IDE, CD, and Disabled. I do have the option to 'boot from other devices' which is set to Yes. I'm at work at the moment, so I'll try my suggestion later today and post the results.

Collapse -

by CG IT In reply to RAID 133 BOOT PROBLEMS

well I can't say for sure on an add on RAID PCI card but I do know that on my MSI boards with the onboard Promise Fastrack IDE ATA133 RAID controller the bootable array is designated as BBS-0(RAID): FT Ary 1 which one chooses in the boot sequence. This is for AMIBIOS. For Phoenix Award BIOS one chooses Boot SCSI and boot other devices enabled.

I know you know but...I say it, the BIOS needs to know boot RAID Array for the BIOS to O/S handoff. Gotta be something in the BIOS one can configure for the boot order to allow boot other devices/boot SCSI. which BIOS????

Collapse -

by CG IT In reply to

Quintar, sounds like when you installed Windows and it asked for 3rd party SCSI device drivers, you may not have installed ALL the necessary drivers. Had the same problem on one of my machines with the Promise Fasttrack SATA RAID controller. There were 2 drivers necessary to install. The 378 Controller AND the SATA controller. I didn't install the 378 driver the first time I put the machine together and had the same problem. Device manager showed the SCSI device but it wouldn't boot. check your floppy and make sure you installed ALL W2K [or XP if your using XP ] drivers are installed even if they look redundant. Try a clean install and specifing all the drivers available on the floppy.

Collapse -

by quintar51 In reply to

Poster rated this answer.

Back to Windows Forum
17 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums