Question

Locked

Raid 5 repair in Windows Server 2003

By lll0228 ·
One of the four drives in my Raid-5 array was not working and needed replacement. All four drives are identical Seagate 500Gb drives. In the Disk Management Console, Disk 4 was listed as "Missing" and the rest of the array is in "Failed Redundancy". I tried to "reactivate" multiple times and the drive was confirmed dead.

So, yesterday I found the Serial number of the missing drive under Device Manager (by elimination, that is), and took out the old drive. I powered it back up and Disk 4 is still missing, just to confirm that I have pulled the right one.

I powered down the server again and put in the new drive in identical hardware configuration as before.

The server started up and recognized my new drive, asked me to format it as a "Simple" volume. As it finished, it was already a Dynamic volume (to my surprise, I thought I had to convert it). And now the new drive shows up as a separate Simple volume by itself.

Following Microsoft's TechNet note, I right clicked on the Raid-5 Volume and tried to click on "Repair Volume", but that option is greyed out. I know for sure that the replacement drive is 100% identical to the old drive, it was bought in a batch, same model. In the Disk Management console, I can still see four drives in the Raid-5 array with one "missing", and the new drive as a separate drive.

What am I missing? How do I "move" this drive into the Raid-5 array, instead of it being a separate individual drive and let it "Repair"?

This array was setup using Windows Server 2003 with SP2, software Raid. It's mostly a file server and I can deal with the slower speed.

Thank you very much.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Free space by deleting simple volume

by anderslu In reply to Raid 5 repair in Windows ...

Hi,

Maybe you have already solved this problem on your own. It sounds as if you formatted your new drive as a simple volume. For use in a RAID array, I believe you need the disk to be initiated but unallocated. Try right clicking on your simple volume on the new disk, then choose to remove it. Now you should be able to repair your array using the new drive.

Collapse -

raid control program

by Sue T In reply to Raid 5 repair in Windows ...

when you boot the server do you see anything that says raid control or something like that during boot? It will have you press keys to enter it. In that program there should be an option to rebuild a drive which is what you want to do I believe. The server may have also come with software that you can install so you can do this within Windows.

Back to Networks Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums