Question

  • Creator
    Topic
  • #2213624

    RDP through WAN

    Locked

    by hanekwj ·

    Hello,

    The company I work for’s accountant asked me the other day if I could make provision for her to access the accounting software via remote desktop so that she does not have to come on site to capture data. (She does this with some other clients aswell)

    So…
    Remote desktop is enabled on the server, I log in from my laptop to make changes to the AD and it works.

    I set port forwarding on the router allowing 3389 to cross in both TCP and UDP form

    I have the routers WAN IP address.

    example: 111:111:111:111

    Then in the Remote Desktop Connection i type 111.111.111.111:3389 but this does not work.

    What am i doing wrong?
    Am I doing anything right?
    What else do I need to enable to make this work?
    Should I disable something to make it mork?

    Any help will be appreciated.

    Thank you in advance.

All Answers

  • Author
    Replies
    • #3027268

      Clarifications

      by hanekwj ·

      In reply to RDP through WAN

      Clarifications

    • #3027080

      Well I’m not expert in this

      by oh smeg ·

      In reply to RDP through WAN

      But generally you need to establish a VPN to access the Internal Server and the Router need to support this option.

      Col

    • #3029069

      firewall?

      by beanxyz ·

      In reply to RDP through WAN

      Did u check firewall yet?
      I think normally VPN is a better solution than NAT on the router.

    • #3027682

      Can you telnet?

      by choppit ·

      In reply to RDP through WAN

      Should be as simple as forwarding TCP3389 (UDP not needed AFAIK) from the WAN interface to the terminal server IP. The port number shouldn’t need to be specified as 3389 is default.

      Can you telnet to the WAN IP on 3389? If not, then something is blocking..

      Check your port forward rule and check from another external network if you can. Maybe ACLs are blocking egress to your IP on 3389.

      • #3027565

        Telnet to port 3389

        by cool_capricorn80 ·

        In reply to Can you telnet?

        open command prompt and write:

        telnet public-ip-address-of-server 3389

        if you get a blinking cursor then port is working fine if not then firewall is blocking it.

    • #3028781

      Agreed, Go VPN Route

      by rkuhn040172 ·

      In reply to RDP through WAN

      Much safer.

      Just port forwarding 3389 to your server is dangerous. Especially if that person doesn’t have a very strong password and/or your Account Lockout Policy is weak.

    • #3028718

      RDP

      by ameack ·

      In reply to RDP through WAN

      Hi,
      If you are using RDC you do not specify the port to connect unless you have a different port set on the router.
      111.111.111.111:3389
      If you just type in the IP 111.111.111.111 it should go straight to port 3389.
      Also do check the firewall settings for incoming traffic.

      This might help, But the best solution would be VPN. This is much safer than RDP.

      • #2871829

        VPN is very safe for your enviorment

        by jacobgc ·

        In reply to RDP

        Do you have any firewall in between check !!
        To make sure port is open just do a telnet to the remote server public ip with port number for RDP , If it responds then you can be sure PORT is OPEN.if not check the firewall.

Viewing 5 reply threads