Question

  • Creator
    Topic
  • #2136134

    RDP / TS Gateway Win XP SP3 not working on only just 1 of 3 PC in a network

    Locked

    by heinz.lyner ·

    Hello from frosty Prague

    I am stuck with a problem and nobody could help me, maybe one of the experts here is lucky…:
    My configuration: 2 PC + 1 Notebook all running Win XP Pro SP3, all updated to the latest state including net frameworks 3.5. All connected to an ADSL Modem to the web through a switch, all get IP and DNS automatically form the router.

    I have to connect to an RDP Server, there are the values (it is a demo installation, no worry)
    Server name: sq-rdfarm1.systematiq.cz
    User: sq\demoabra21
    Pass:#### (not important)

    Im learnt, that you will not find an IP for this, as it connects through a TS gateay, who’s name is moje.Abra.eu (but with RDP client 7.0 you do not put this value anywhere? I just know it because I also tried am Android RDP client, where you DO NEED a client who allows to put the TS Gateway)

    On 1 PC and the Notebook all works with just the servername and the credentials (also on the Android client with the TS Gateway!) On the second (my) PC I always get the message that this server is unknown. I tried another external RDP Server from this PC, works fine. Of course the first thing I tried was checking the DNS gateway, but it is on automatic. I checked also the hosts file and replaced it by an empty one. Nothing.

    Now I am at the end, any routing in the router would influence all clients, so the problem is definitely on my PC, but where? This PC was earlier part of a domain with Window SBS 2003 and ISA2004. Could it be, that somewhere in registry is influencing the TS Gateway detection? Obviously that’s what is not working.

    Any help highly appreciated! thanks in advance!

    Heinz

All Answers

  • Author
    Replies
    • #2903417

      Clarifications

      by heinz.lyner ·

      In reply to RDP / TS Gateway Win XP SP3 not working on only just 1 of 3 PC in a network

      Clarifications

    • #2903366

      Check event log

      by gechurch ·

      In reply to RDP / TS Gateway Win XP SP3 not working on only just 1 of 3 PC in a network

      Check your event log – “Applications and Services Logs” > “Microsoft” > “Windows” > “TerminalServices”

      Some random things to try though:
      Does the affected PC have the updated RDP client installed?
      Can you ping the TS gateway address?
      Does it work if you use the IP address instead of DNS name?
      Does it work from Safe Mode with Networking?

      • #2903336

        Reponse To Answer

        by heinz.lyner ·

        In reply to Check event log

        Hello and thx!
        – in Win XP I have no such event log
        – yes 7.0 incl. hotfix is installed on all 3 PC
        – the ping is translating the gateways DNS into IP but 100 % lost:
        ping moje.abra.eu

        Pinging moje.abra.eu [195.146.103.229] with 32 bytes of data:

        Request timed out.
        Request timed out.
        Request timed out.
        Request timed out.

        Ping statistics for 195.146.103.229:
        Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

        – the servers IP adresse alleegdly cannot be translated into a direct IP as you access through the Gatway,
        – I will test safe mode, but don’t expect wonders

        Rembember on 2 PC it works, you can try yourself :
        sq-rdfarm1.systematiq.cz

      • #2903286

        Reponse To Answer

        by heinz.lyner ·

        In reply to Check event log

        Checked out also Save mode, no change

Viewing 1 reply thread