General discussion

Locked

read-only attribute XP-pro

By thasenkamp ·
I just upgraded a user from Windows 2000 to Windows XP professional. Everytime I create a file on the disk (C: drive) the file is created as a read-only file and I cannot write to this file. I have admin privledges on my user id; but once I go to properties and uncheck the read-only box, hit apply, and OK, I than go back into the properties and the read-only is still there. What is the deal?

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

That is one of XPs "features"....

by caestelle In reply to read-only attribute XP-pr ...

For some reason, that I do not understand.... Microsoft decided to make all files and folders appear to be read-only in Windows XP. Don't ask me why...but it is true.

Collapse -

how do I get rid of this?

by thasenkamp In reply to read-only attribute XP-pr ...

I need to write files to a CD but are unable to modify them b/c of the Read-only capabilities.

Collapse -

You don't..

by caestelle In reply to how do I get rid of this?

Although, they are marked read-only...they really are not read-only

Collapse -

clarification please...

by jennyn In reply to You don't..

could you clarify the "feature" for me? I have recently seen something like this - small org - Win2k/XP workgroup.

File located on XP PC being seen as read-only by W2k machines. Can see this but not change it from the security tab on the Wk2 machine, but cannot change it on the XP PC.

Is this related? or is this a different "feature"?

Collapse -

Yes, you can turn the read-only off...

by TX383 In reply to read-only attribute XP-pr ...

Guys,
After letting XP lead me a merry chase through the file properties/permissions, I found it. Go to Control Panel, select Services. Find "Protected Storage." Set it to MANUAL. Do not disable. Guess what, you can now permenantly change your attributes and it sticks....
Debster

Collapse -

Yes, you can turn the read-only off...

by clay.lindsay In reply to Yes, you can turn the rea ...

You are mostly correct but some XP and 2003 machines do not show "Services" under the Control Panel therefore do a right mouse click on "My Computer" Icon and then choose "Properties" and then choose "Manage". You will always be able to get to "Services" that way...!!

Collapse -

Or you can ...

by heavener In reply to Yes, you can turn the rea ...

"Services" is also in "Start > All Programs > Administrative Tools"

I use an add-in called Properties Plus for a lot of features that were forgotten in NT and never subsequently added back by Microsoft. Among other things it ... tells the truth about attributes and allows you to change them for a file or a folder or all the files and folders. I got it off the Internet a couple years ago and keep it in my Essentials toolkit right beside WinZip.

Sometimes it's easier/quicker to jump to a command prompt and change attributes manually. If you don't know how, email me at mqheavenr@yahoo.com and I'll send directions.

Michael Heavener

Collapse -

Thank you from the future

by Marc L In reply to Yes, you can turn the rea ...

It's 2007, but your answer helped. Thanks to the people of 2005.

Collapse -

Doesnt work

by jkmcdonald2003 In reply to Yes, you can turn the rea ...

This doesnt work. After you set it to manual, the Read Only flag comes back.

Collapse -

I m still getting this problem

by sagarsparekh In reply to Doesnt work

Hi All,
After setting the service type to manual, the problem is not getting solved.
My OS is WinXP pro.Would you please tell me some suggestions?

Back to Hardware Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums