Question

Locked

Rebooting Servers

By wancona ·
I know that Servers are meant to remain running, but upper IT management wants them restarted daily. Is this a good idea, or should it only be done once a week, once a month, or not at all. Not quite sure. Any help is appreciated.

This conversation is currently closed to new comments.

12 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

We reboot

by cmiller5400 In reply to Rebooting Servers

We reboot our Citrix servers nightly. But it is justified that with so many users logging in and out, they become unstable after a while so a nightly reboot does solve an issue. File servers only get rebooted when there is an issue.

The real question is WHY do they want them rebooted nightly. I had a Novell 3.12 server that was up for over 2 years without issue...

Collapse -

It depends on what the server does.

by bart777 In reply to Rebooting Servers

A highly used Terminal server should be rebooted nightly.

An application server, maybe weekly.

A print server, maybe monthly.

A file server... Whenever a patch requires it.

There is no reason to reboot a server every night unless you are usign Terminal server\Citrix and have a lot of traffic on the boxes each day.

There are also other factors to consider. You don't want to have all of your DCs rebooting at the same time. If they come up after the other servers do then authentication may get fouled up. SQL servers need to have backups done thru the mantainence plans but don't need to reboot nightly. This may actually HURT the server. The same is true for Exchange. Do nightly backups and reboot about once a week or once a month.

I work in a very large Enterprise and we reboot the majority of our servers once per month. The only deviation from that is out Citrix farm which reboots every other weekend.

Hope this helps.

Collapse -

SBS

by wancona In reply to It depends on what the se ...

The server is an SBS 2003 Server. We are a small company with 30 employees. I believe they wanted the server rebooted becuase they believe that it staying on, the ram is getting "stuck" and it is pushing the 4 GB memory limit. But, it's the only server we have, and I'm worried that it will diminish the life of the server by nightly restarts.

Collapse -

I see..

by bart777 In reply to SBS

Ok,
SBS is a funny animal. Once a week might be good in this case.
However I would take a look at what's eating all of the memory. Perhaps a bit of tweaking would help with the problem.
If you are using SQL on this server you will be constantly be running low on RAM. It can be a hog. You will want to do a bit of research into reducing the footprint there. Also Exchange can be a culprit. The store.exe can have a similar effect.

Take a look at you swap file size too. It need to be 6GB if you are running with 4GB of RAM. This can take some of the pressure off as well.

Even with all of these program running on customer SBS servers in the past I never had to reboot more than once per week.

Let us know what's eating all of the RAM. Maybe we can help with a better mousetrap.

Collapse -

SQL and Swap

by wancona In reply to I see..

SQL is using up most of the RAM. There are 7 instances of sqlserver.exe running in the processes tab of task manager. I don't think that we even have 7 databases for all them instances to be running. We are using it for our QuickBooks database, and for our SharePoint. I've disabled the Exchange services because we do not use the Exchange server postion at all.

How do you view and edit swap file size. I know how to do that in Linux, but I didn't know Windows had an edit-able one also.

Collapse -

Properties of My Computer.

by bart777 In reply to SQL and Swap

Open the properties page.

Go to the advanced tab.

Select the Settings button for Performance.

Select the advanced tab.

Hit the change button on the bottom to get to the Virtual Memory settings.

Make sure that you have at least 6GB for what you are running.

Have fun!

Collapse -

Swap Size File Settings

by wancona In reply to Properties of My Computer ...

I was unable to make the swap file 6 GB. I recieved an error message that pretty much said that the maximum had to be greater than the minimum and less than 4096 MB (which is 4 GB) so i guess that your max can only be as high as your physical RAM.

Collapse -

Try this...

by bart777 In reply to Swap Size File Settings

Set the Min to 6140 and the max to 6144.

That should do the trick for you. Normally you would just do 6144 for both min and max.

Collapse -

Here you go

by cmiller5400 In reply to SQL and Swap

System Properties
Advanced Tab
Performance Tab
Advanced Tab
Under Virtual memory click Change
Click the drive you want the swap file on and then set it to custom size and specify 6144MB as the initial size and Maximum size. ok to all of the messages.

You may need to reboot the server.

Collapse -

If SQL or Quickbooks are the culprit

by Churdoo In reply to SQL and Swap

If you can't tweak the settings to eliminate the runaways, then perhaps you can restart some of the services with a batch file.

First, I agree with Bart about SBS and not needing to reboot it more frequently than once a week, and everything else he's said. And I also agree with you that you should tell Management to STFU and let you run the server.

But if you can't eliminate these runaway memory hogs for whatever reason, rather than admit defeat and reboot the server each night, try restarting just the database services, like the QuickbooksDataXX services and/or the SQL Server service with the NET STOP / NET START commands. This will be much gentler than restarting SBS.

Back to Networks Forum
12 total posts (Page 1 of 2)   01 | 02   Next

Related Forums