General discussion

Locked

Redirected printers are deleted when logging into Windows Server 2003 T/S

By gmunk ·
Just recently my clients who log into a Windows Server 2003 terminal server no longer have some of their local printers redirected for use in the t/s session. This was fully functional until I applied the latest updates for Win 2003. The system event log was showing "Kernel mode printer driver blocking is enabled". I thought maybe the new updates set this by default, so I disabled kernel mode printer driver blocking in group policy. Now the printers still aren't being redirected and the system event log is reporting "Printer HP LaserJet 8100 Series PCL 6 on lumber2k (from PC64) in session 6 is pending deletion." and "Printer Brother PCL4 Driver (from PC64) in session 20 was deleted." The printer is never even created, but yet it says it deletes it when logging in. I've restarted the server and print spooler service on the terminal server. I'm stumped. Does anyone have any ideas?

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

No big deal

by cfarley In reply to Redirected printers are d ...

In Control Panel, open Printers and Faxes.
On the File menu, click Server Properties.
On the Advanced tab, clear the Log spooler information events check box.

Collapse -

ME TOO!

by Lovs2look In reply to Redirected printers are d ...

Yeah just applied MS updates this morning to our Win2K AdvServer, and now clients using remote desktop can't connect. No error msg, just logs in and then back out just as quick. A check of the event viewer confirmed the above print spooler errors...but I had 10 printers in my profile and it tried to load all of them!
Unfortunately I'm stumped too...searching MS web sites for a fix, but not coming up with much. Can anyone help us????

Collapse -

Progress?

by SteveMurphy In reply to Redirected printers are d ...

GMunk,

Did you resolve your problem? I do not have anything to add other than my Terminal Server is experiencing the same problem.

SteveMurphy@roi.cc

-steve-

Collapse -

Progress...for me, Yes!

by Lovs2look In reply to Progress?

My issue was *embarassment* the bloody google toolbar blocking pop-ups. We were using web pads to log into a server and run a browser session. The browser was blocked and TS logged us out ASAP. Unistalled google toolbar (and yahoo just to make sure) and now works fine. The printers issue was a TS property...can't remember exactly, but unchecked use local printer (which we don't need) and all works as it should...Now.

Collapse -

Also experiencing this issue

by stewarts In reply to Redirected printers are d ...

I can find very little regarding this issue online, no matter what seatch phrase I use.

I have made no headway in solving this issue, despite 2 days of trying. I'm out of ideas. The only thing left to try is taking off some of the MS Updates - but I don't know which one. Can anyone shed light onto which update may have caused this issue?

The trouble is, it's only 1 machine that is affected, and it was a clean install of XP SP2 so it should just work.

Help please.

stewarts 'at' redeemplc.com

Collapse -

Also this issue

by alanfranconi In reply to Redirected printers are d ...

I am having this issue too, does any one have a solution? TKS a LOT
Let me know at alanfranconi@urudata.com

Collapse -

Had Similar problem - Resolved

by dlippiatt In reply to Redirected printers are d ...

Had a similar problem. I installed a new application on the terminal server and the printer redirection stopped working. Same symptoms. First I removed the new application. Still message in the event log said the printer was deleted and it never showed up under printers. First I determined redirection was working by installing a generic text printer under a admin user /console session. Then I logged in as the same user from the session using mstsc under localhost. The generic text printer showed up. This confirmed redirection was working but it was a driver issue. The new application I had installed had added some PDF converter driver. I removed that from the drivers in server properties. Then I removed and readded the Hp Deskjet 990c (one I was having problems with). Also, I might mention that one of the troubleshooting steps was to use/install the terminal service printer redirection tool. After removing and adding the HP Deskjet 990c (I am using this as a generic driver for some HP Officejet Printers) low and behold the printer showed up. Also I even had a remote printer using a TCP/IP port show up (because I had mapped it to the Deskjet 990c through the redirection tool) and this was not working before. Apparently one of the drivers added (PDF Converter) was conflicting with others printer drivers. After removing the offending driver and remove/add of driver I needed..things worked. Hope that helps. Client was a Vista client but same symptoms were on an XP Client also.

Collapse -

Thanx,

by gaurangrpatel In reply to Had Similar problem - Res ...

First of all i would like to thanking you to post your experiance,
I read your post and solve my problem it is really good one.
now i also like to share my exp. with people.

regards,

Back to Networks Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums