Question

  • Creator
    Topic
  • #3937775

    Reenabling DCOM

    by doniel ·

    A couple of days ago, when booting into Win8.1, I encountered the infamous “Your PC ran into some problems etc.” I was able to boot into Safe Mode and checked Event Viewer. The issue had something to do with DCOM. Since this is a home, standalone computer, I disabled DCOM, and was able to boot into regular mode.
    I don’t believe that I NEED to reenable it, but I’d like to. I tried DISM and SFC, without success. Even when I specified a source for DISM and pointed it to a Win8.1 iso, it came back with “Unable to download files.”
    Bob, I know you’ll probably counsel me to leave well enough alone, but I’d really like to enable it again, so please focus on helping me do that.

You are posting a reply to: Reenabling DCOM

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our Community FAQs for details. All submitted content is subject to our Terms of Use.

All Answers

  • Author
    Replies
    • #3939044

      Sorry.

      by rproffitt ·

      In reply to Reenabling DCOM

      But those memories are long gone. Maybe something with a google will find a solution.

      • #3939024

        I only posted after

        by doniel ·

        In reply to Sorry.

        searching with Google.

    • #3939033

      Re: DCOM

      by kees_b ·

      In reply to Reenabling DCOM

      You write “the issue had something to do with DCOM”. That’s too vague to say anything sensible.

      The more you know of the error, the bigger the chance that you can find out how it can be solved without installing Windows 8.1 again. But since it’s only needed inside a network, so unnecessary for you, it’s your choice if you want to have a system that does all you need or a system that can also do things you don’t need.

      It’s never wrong to spend time on a hobby (like running Windows 8.1), even if some people might say it’s a waste of time when you can run Windows 10 without errors like this.

      • #3939023

        Considering that

        by doniel ·

        In reply to Re: DCOM

        there are still people running Windows 7 and even XP, I’m doing pretty good. There’s always a learning curve when “upgrading,” and not everyone wants to spend time doing that for questionable benefits. I still use Word 2003 and it does everything I need. A lot of people MUST have the latest and greatest. And then there are those of us who are satisfied with what they have, as long as it fills the bill.
        I do understand what you’re saying, Kees_B. I’m just explaining my position.
        As to the specific issue I had with DCOM, I don’t recall (since it didn’t mean anything to me). I just checked Event Viewer, but it only goes back to Dec. 20th. That’s strange. I try to reboot as infrequently as possible, but next time I do, I’ll reenable DCOM and make a note of the error message, which I’ll then post here.
        Thank you.

        • #3938923

          DCOM error

          by doniel ·

          In reply to Considering that

          I’m confused. (What’s new?) I never renabled DCOM, but it’s enabled again and running (automatically). As if that weren’t enough, Event Viewer shows over 57,000 error messages over the past weeks, all of them the same. Source is DistributedCOM and Event ID is 10005.
          DCOM got error “5” attempting to start the service WSearch with arguments “Unavailable” in order to run the server:
          {B52D54BB-4818-4EB9-AA80-F9EACD371DF8}

        • #3938922

          That doesn’t look like an “error”

          by rproffitt ·

          In reply to DCOM error

          Event viewer can log informational events as well. Can be unsettling to some.

          Due to how this all works, it’s why logs and such have limits. However a quick look at https://www.google.com/search?q=%7BB52D54BB-4818-4EB9-AA80-F9EACD371DF8%7D&rlz=1C1GCEA_enUS960US960 finds folk wipe and install a clean version of Windows very often.

          That is, Windows is known to get damaged and no one wants to pay Microsoft’s own support to fix this install. Cheaper, faster to start over.

          And yes that upsets those that feel it shouldn’t be that way. What to do? Keep backups of your install as you like it and don’t tinker much with the inner workings.

        • #3938918

          They’re identified as errors

          by doniel ·

          In reply to That doesn’t look like an “error”

          If they’re not errors, why does Event Viewer assign them the “Error” designation under Level?

        • #3938917

          “This is Windows.”

          by rproffitt ·

          In reply to They’re identified as errors

          This is not a perfect OS. There are many prior discussions about this area, both this error/warning and Windows that I can’t duplicate all that here.

          So how do I deal with such things? I look to what is not working. I don’t look at the Event Viewer and then try to clean/fix what I find there. I start with “this doesn’t work” and then use the event viewer as possible clues to why “this doesn’t work.”

          Once in a while you’ll encounter someone that wants Event Viewer to be “clean.”

        • #3938916

          Gotcha

          by doniel ·

          In reply to “This is Windows.”

          I’m going to go off topic because I don’t want to start yet another thread and I expect this to be a short question and answer.
          My external drive WD My Passport Ultra has been giving me lots of trouble. (It used to be my destination drive for system / disk images, and imaging frequently either didn’t complete because of drive errors or failed verification.) Yet, it passed all 3 tests on WD’s own Drive Utilities tests.
          Due to its size – 4GB – and the slow USB speed, low-level formatting would take something like 35 days. The only program I’m aware of that allows you to resume where you left off is Spinrite. However, Spinrite, which runs under DOS, only supports external drives with a DOS device driver, which WD doesn’t provide.
          Are you aware of any alternatives?

        • #3938914

          4GB? You sure about that?

          by rproffitt ·

          In reply to Gotcha

          I haven’t seen a 4GB drive in over a decade.

          If the drive has failures, that’s one problem but USB powered drives have common problems such as pushing the USB power too hard or the client lost the USB cable the drive came with. Sometimes you can get it back with some Y cable USB power booster cable.

          Alternative drive test? Look up HDTUNE.

        • #3938888

          4TB!

          by doniel ·

          In reply to 4GB? You sure about that?

          Sorry about that.
          HDTune. That’s a program I haven’t seen in years. Thanks for reminding me. I downloaded it and it’s running right now (and tom’w., and the day after that, and next week . . .).
          The first 3 blocks (each representing 1.6GB) are green and the next 2 are red. If those are the only problematic ones, I’ll try to set up a snall partition of 10GB as the first partition, which I won’t use. Hopefully, that will do the trick.

        • #3938887

          There’s a meme for this.

          by rproffitt ·

          In reply to 4TB!

          [image]https://i.imgur.com/v1PVP2a.jpeg[/image]

        • #3938886

          :-)

          by doniel ·

          In reply to There’s a meme for this.

          That IS Ben Obi-Wan Kenobi, isn’t it?

        • #3938885

          Now that’s a name that I’ve not heard in a long time.

          by rproffitt ·

          In reply to :-)

          A long time….

          The meme seems to fit with your comment about HDTUNE.

        • #3938877

          I understood that

          by doniel ·

          In reply to Now that’s a name that I’ve not heard in a long time.

          I was just wondering if I’d properly identified the meme.

Viewing 1 reply thread