Registry: Error opening key - can't delete it

By marshall1956 ·
I have a key in the registry I can't open or delete. I get the error message "Error opening key - Cannot open keyname: Error while opening key."

I have read as many posts as I can find but no help. Everyone talks about being sure you have adminstrator rights, assigning right to the key, safe mode. No one seems to have any ideas after that. I've tried booting into safemode, signing on my account with administrative privileges or the default adminstrator acoount. I've tried to assign the key Full Control and check box to replace all child objects for Administrator and All Accounts, and it works for all but the problem key, get error message: "Registry editor could not set security in the key currently selected, or some of its subkeys."

This all started when I tried to update Windows Media Player to version 11 so I can download and play files from my TIVO. I have version 10 and they say I have to upgrade to version 11 to play the files. In running the upgrade it always fails at the very end. The log file gives the error message as access denied on the key HKLM\Software\Microsoft\Mediaplayer\Settings\MP3encoding\lowrate. One suggestion given to me to fix it was to delete the key in question and reinstall. Well I can't access HKLM\Software\Microsoft\Mediaplayer\Settings so there are no subkeys. I tried to open all the subkeys under HKLM\Software\Microsoft\Mediaplayer and I can open everyone except ...\Settings and ...\Player\CDData. I can open ...\Player\Extensions.
How do I fix or delete or rename the key in question? I'm in safe mode, I'm in the administrator account, I've tried to change the permissions for the parent key and give to the child key, so please don't suggest doing that again. I can't rename it or insert another key with the same name.
When Mediaplayer 11 fails it resets to Mediaplayer 10 which still works, but I'm frustrated that I can't access or change the keys in question.
Windows XP SP2, McAfee antivirus, I've scanned with Spybot S&amp and Adware-SE.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Are you

by Jacky Howe In reply to Registry: Error opening k ...

using Regedit.exe to do this or Regedt32.exe.
Regedt32.exe gives you a lot more control over the Registry.

Collapse -


by marshall1956 In reply to Are you

I thought with WinXP that regedit32 went away and just have regedit now.

Collapse -


by Jacky Howe In reply to regedit32

you try it. regedt32.exe

Collapse -

Tried regedt32

by marshall1956 In reply to Did

I went to Start/Run, regedt32.
Started regedit, the same program that runs when I run regedit: Microsoft Registry Editor v 5.1. Get the same errors.

Collapse -

Follow this link

by Jacky Howe In reply to Tried regedt32

It will allow you to set the Registry Settings back to default.

To reset the registry permissions, add this to the secedit command line:

/areas REGKEYS

Collapse -

Maybe just a bad key?

by alxcsby In reply to Registry: Error opening k ...

Try running a program like boostxp to root out bad registry keys and delete them. Then maybe try a reinstall.
Just a thought, probably not the answer you'd want though.

Collapse -

A way to delete keys

by bojek In reply to Registry: Error opening k ...

Hey, I had similiar problems with not being able to remove keys. After many reads, tries I came up with this solution:

1. on key that gives you msg "error deleting key", add yourself with full control to permission, apply
2. go advanced, owner tab, check "replace owner on...", click OK, you'll get an error but just ignore it
3. refresh, that will give you access to subkey
4. now you'll be able to able to change permissions on the subkey and eventually delete the lowest subkey

follow these step to delete each level of keys individaully.

I know it's painful and lots of clicking but can be done.

Please post reply if helped

Collapse -

Re: A way to delete keys

by pdesrivieres In reply to A way to delete keys

I also am having the problem that several keys are corrupted and I can't delete them. I think this is related to my computer losing power while shutting down.
First I go into regedit/regedt32 as an admin user. When I right-click on one of the keys an select Permission... I get the message that I don't have access to view the permissions but may change them. I give Everyone full control and hit OK but then I get an error message that I can't save the changes to the permissions. I click Cancel and hit F5(refresh). I'm still unable to access or delete the key!

Collapse -

It works following your direction!!!

by tt111r In reply to A way to delete keys

Here is the step I use to unlock the key using regedit:
1) right click on the problem key
2) select Permission and click OK
3) add yourself to Group or user names
4) give yourself Full Control
5) click Advance
6) Choose Owner tab
7) Change Owner to yourself and check the box to Replace owner ... and click OK
Ignore the Access denied error message
9) click OK twice
10 Voila, you have full access


Collapse -

A big Thank You

by sdubbs In reply to It works following your d ...

I just wanted to reply letting you know that this worked for me also. I did get the access denied error trying to apply it. I had the choice to retry or cancel. I hit cancel and then ok out of the permissions area and voila -- full access.

Related Discussions

Related Forums