General discussion

Locked

Regsvr32 fails

By bob ·
I tried to post this in the Ask A Question, but it kept saying "Select a Topic" and there were none to select. So, I put it here.

I am trying to unregister an older DLL in one location, and register a newer version in a different location. However, it doesn't matter what I do, either register or unregister, Regsvr32 fails. I get the following message:

dllname "was loaded, but the DLLUnRegisterServer (or DLLRegisterServer if trying to register) entry point was not found."

MSDN say that is the message you get if you're trying to register something other than a DLL, but this is a DLL. It's the Crystal Reports U2fcr.dll that has to be in the WINNT\Crystal folder for my DLL to export a report to PDF.

The error message suggested using PView to view and remove the DLL, but I ran PView and it didn't show it.

This is the last piece of the puzze for a very important app, and I am pulling my hair out here!!

Any help, insight, answers, advice, correction or direction is GREATLY appreciated.

Thanks,

Bob
vbcodehead_bob@hotmail.com

This conversation is currently closed to new comments.

0 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Back to Web Development Forum
0 total posts (Page 1 of 1)  

Related Discussions

Related Forums