It appears my problem is with relay domains. So I go to start/programs/option pack/iis/smtp and add the computer names for the machines I am testing from. I then send a test message and it gets denied – Relay Denied.
I also have a FreeBSD box running sendmail. The only options I have changed from the default is I added the same machine names to the domain relay list. It works fine.
Why won’t Exchange also work?