Question

Locked

Remote Desktop connection problems

By jfuller05 ·
I've been using the remote desktop connection for me and a user outside our network to login to our server(a) for certain things. This week, the user calls and says she's not able to remotely connect to the server(a). I tried to remote in (I'm in the network) and I couldn't connect either. However, I was able to remote in to our other server(b).
I can see and access files on the (a), but I cannot connect to it to use remote desktop. Everything is fine with TS licensing, I couldn't find any problems there. Also, even if there were TS problems, shouldn't I still be able to use remote desktop (I believe at least one user can) without TS? I think so, so that makes this problem even stranger to me.
Anyway, the user was able to get her work done another way, but I still want to fix this problem. I believe it would be a hardware issue.
Any suggestions?
The user logins via VPN through our SonicWall, but I don't think that is an issue, since I can't even establish a connection within the network. Port 3389 is open for remote desktop. So it's not a firewall issue.

Server A: Windows Server 2008 standard.
Server B: Windows Server 2008 R2
Client Machines: Windows XP Pro SP3

This conversation is currently closed to new comments.

34 total posts (Page 1 of 4)   01 | 02 | 03 | 04   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Use TS Manager and TS Configuration

by markgreenhall In reply to Remote Desktop connection ...

I had a similar issue with terminal services sessions not being closed properly (sessions remained open and eventually the server would not allow any more).

I would physically go to the server, log on, open Terminal Services Manager under Administration Tools and disconnect / log off and active profiles. Afterwards try and connect from your machine again.

If successful then it will have been due to existing open sessions from previous connections.

To avoid in the future then go into Terminal Services Configuration and right-click the "RDP-Tcp" connection. Under the "Sessions" tab tick to override the disconnected and idle sessions and set the time to say 3 hours (or maybe something like 8 hours). This will clear out and sessions that have been left open after a user has logged off and allow you to reconnect.

Regards
Mark

Collapse -

I appreciate the suggestion...

by jfuller05 In reply to Use TS Manager and TS Con ...

but it didn't work. I tried logging off in TS manager, then going to my computer, and using remote desktop; it didn't work.
I then tried disconnecting, it didn't work either.

I forgot to mention that I restarted the server, in hopes that would solve it; it didn't work though.

Thanks again though. I'll remember to set the RDP-TCP settings whenever I can remote in to the server.

Collapse -

so you disconnected open sessions?

by CG IT In reply to I appreciate the suggesti ...

rebooting should have closed any open sessions.

So when you log on locally to the server, then view open sessions, are they any? if not, check the remote desktop settings.

you might want to, just out of curiosity sake, set RDP to deny and remove the users, click ok, then go back and set it to allow, and then add the users. Window Servers are sometimes funky with registry values, remembering a certain configuration even after you change it until you reboot the server even if it doesn't prompt you to reboot.

Collapse -

Yeah, there is the open session

by jfuller05 In reply to so you disconnected open ...

for me, the Admin, but no one else.

I set the RDP just as you said to, but I still can't remote in from my desktop.

Thanks for the suggestion though.
This is definitely a mystery to me!

Collapse -

so are you using the server name or address?

by CG IT In reply to Yeah, there is the open s ...

or have you tried both?

Collapse -

I've tried both.

by jfuller05 In reply to so are you using the serv ...

I know it has to be a setting that I'm missing in that server.

I'm able to remote in to our other server.

Collapse -

RDP

by christianshiflet In reply to Remote Desktop connection ...

Did anything change on the server recently? Was it made a DC, updated, or even just rebooted or have a GPO modification? Can you verify that the Windows Firewall didn't either re-enable itself or have GPO changes impact it? Also, can you verify that the Terminal Services service is running (and maybe restart it, just to be sure) and that Remote Desktop is still enabled under System Properties - Remote and the users in question are listed in the appropriate groups to access TS? Lastly, does the event viewer show anything useful regarding TS such as denied connections or firewall blocking? Let me know. Thanks.

Collapse -

RE:

by jfuller05 In reply to RDP

No recent changes.
It's been and still a DC.
No updates. Most recent updates were from early June. None that would affect this b/c I've been able to remote in from within the network and the outside user was able to after the updates.
Windows Firewall didn't re-enable and no GPO changes.
TS was running, restarted, and running now.
Remote Desktop is still enabled.
Users are in the appropriate groups.

No firewall blocking in event viewer. There were some events regarding the TS licenses though, but I reactivated them and now the licenses are good to go in TS license manager. So it's not issuing temp licenses anymore.There were also events for Time sourcing. The time was out of sync, I re synced it though.

Still, can't remote in though.

I appreciate the suggestions.

Collapse -

Router?

by seanferd In reply to RE:

Is there a router or switch between the workstation and the TS? I'd try rebooting that, if there is one.

If it keeps logs, maybe check those first.

Collapse -

Thanks, I'll try that and get back with you. no text.

by jfuller05 In reply to Router?
Back to Networks Forum
34 total posts (Page 1 of 4)   01 | 02 | 03 | 04   Next

Related Discussions

Related Forums