Question

Locked

Remote Desktop fails after login only when on wifi

By 10Gig ·
1.) HP nx9010 Laptop: Format and install of WindowsXP Pro on 9/16/2010. SP3 and latest HP drivers installed.
2.) No issue with RPD to or from over Wireline.
3.) No issue with RDP to other PCs over WiFi.
4.) Wireline physically disconnected during WiFi testing and troubleshooting.

RDP to the unit displays the logon screen but fails AFTER username and password submitted.

FYI: Pings to WiFi nic stop immediately following clicking OK on the Winidown Log On box. AP does show the client as associated.

This conversation is currently closed to new comments.

12 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Clarify

by robo_dev In reply to Remote Desktop fails afte ...

So you're connecting TO this laptop, or from it?

What AP are you using?

What type of WLAN security?

Since the WLAN security settings are stored in the Windows profile, and the profile does not get activated until you login, the security settings for the WLAN must be hosed for that profile.

Is there a personal firewall on the laptop?

Are you using Windows to manage the WLAN adapter or a client utility?

If you turn off WLAN security, letting is connect unencrypted, does it still fail?

Collapse -

Additional information as requested.

by 10Gig In reply to Clarify

The issue is when connecting TO it on WiFi only.

APs are Cisco 1242AG thin mode connecting Cisco WiSM blades in a Cisco 6500.

The WVLAN for the testing is WPA2-PSK. All others are WPA via authentication.

Windows firewall: off
No other firewall software.

MTU on the WiFi set to 1400 but still same results.

WiFi nic is Broadcom and am using that utility.

I do not have the ability to connect to an open WLAN and can not enable one at work. It would generate alarms on our separate network monitoring system.

If no obvious known issues, I will have to take the unit home and try.

Collapse -

Hmmm...is this PC in a workgroup or domain?

by robo_dev In reply to Additional information as ...

If on a domain, maybe there's a group policy that's getting involved?

The fact that it drops once you login points to a Windows policy/security issue.

Collapse -

RDP over WiFi

Might be something else, but... This may be worth a try.
It may be a case of certificate error/mistrust,etc. Recreate the connetion and when prompted to view the cert place the certificate in the computer's Trusted Root Certification Authority.

Deduct 2 cents...

Collapse -

Never am presented any cert prompts

by 10Gig In reply to RDP over WiFi

I have use Remote Desktop to gain access onto many systems and to my knowledge, have never been prompted for cert info. I am using mstsc for these connections.

Collapse -

Update - Attempt on AP with Open security

by 10Gig In reply to Remote Desktop fails afte ...

Purchased an new inexpensive Belkin Connect AP, needed a spare anyway. Set the unit up wide open and getting exact same results.

Collapse -

are other

by Sue T In reply to Update - Attempt on AP wi ...

computers able to connect wirelessly using remote desktop to the same computer that this one fails with. can this laptop connect with remote desktop and keep the connection to another computer?

Collapse -

Firewall?

by TobiF In reply to Remote Desktop fails afte ...

If the target would have been using Vista or Win7, then I'd ask you to check what "network locations" are attached to ethernet vs the wireless network in question.

But still, try to see if Widnows firewall somehow uses different settings for different SSID or for different types of connections.

Collapse -

In Windows XP make sure that

by robo_dev In reply to Remote Desktop fails afte ...

Make sure 802.1X authentication is disabled in XP if you're not using it.

Collapse -

Had the same problem, now fixed

by dgibb2000 In reply to Remote Desktop fails afte ...

I've had this problem ever since getting a new laptop from work. I tried RDP on my home network from an XP machine, or from 2 android devices like i had been able to do previously. The new machine is a windows 7 64 bit laptop. Whenever i would connect via RDP over wireless as soon as I logged in the wireless connection would drop. Confirmed this via pings to and from the remote machine.

I connected the laptop to a wired connection and RDP'd to the IP address i assigned to wired interface and got in without a problem. I then noticed that the wifi had dropped like it had previously. I relaunched the wifi connection from within the RDP session and was prompted for my network's security key. I thought this was strange since my user profile already had that saved. Once I entered the key I was able to connect to wifi. I disconnected the wired ethernet connection, and then successfully connected via RDP to the wireless ip address for the first time! Looks like something must be different with a RDP user profile and one locally logged in. The remote profile didn't have the wifi security key saved and explains why when switching to this user would kill the connection.

Back to Software Forum
12 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums