Question

Locked

remote desktop + open ports

By kev.clark ·
Greetings Guys.....

Have a computer at my office that has a linksys router attached. All works great.
This unit is refered to as our psuedo server. No one works on it, it has XP Pro and handles all of our devices. We have 3 other computers networked with it using a workgroup...all works nice.. I need to use remote desktop to get to my 3 pc's on this network from my home office. Using remote desktop I use the following to get to the router then Pc. example 38.141.181.12:3389,, this gets me thru the router and to the PC (ip) that I have listed in the router setup under single port forwarding using port 3389... Problem is it seems like i can only use 3389 once and point it to one IP as per router software... I can change the IP address and get to any/all computers, but I can't set the router to let me get through to all 3 (without changing the port forward IP address). every time i try to forward 3389 (on more than one line in router software, it won't accept it)....I have set to other open ports (used netstat and found listening ports)but remote desktop won't connect to these.....how can I add the other 2 IP address's to this port...

thx
Kev

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

thoughts

by jck In reply to remote desktop + open por ...

you should be able to set all your computers to allow remote desktop under xp pro.

when you connect to the PC in your network, that PC would have to be setup to have a connection for remote desktop to each of those other computers in your network.

the only thing I can think of is that you might have to establish port forwarding in your router maybe, if the other 3 PCs won't talk to any IP other than your Main PC attached to your router.

you could establish a VPN..then once connected to that inside your network, connect to any of the 3 pcs by separate IP address.

Collapse -

Change Listening Port

by NormH3 In reply to thoughts

If you do not want to go through the single PC to access the others, you can change the RDP listening port on each of the PC's to something other than 3389. For instance, PC1 would listen on 61001, PC2 would listen on 61002 and PC3 would listen on 61003. The listening port can be changed in the registry and after a reboot will be available. A port forwarding statement would have to be added in the router for each PC. A search in the registry for 'RDP-Tcp' will lead you to the port configuraton for RDP.

Collapse -

This information isn't complete.

by Kiurcher In reply to Change Listening Port

The explaination works with only one PC. I'll explain.

If you are logging into one system nothing needs to change.

If you are logging into two PC's on the same network. They conflict and neither connection works if you do not change the port on one of the PC's you wish to connect to.

Once you have changed the port and have individual ports for both PC's this method still only allows you to connect to one of those two PC's.

Adding the port behind the IP doesn't work as it doesn't accept it.

If I had seperate IP's all together I wouldn't need to change my ports at all. But being that I am riding on the same IP this solution is still unresolved.

Ports are open via Router for both PC's and have their own individual port numbers 3389 and 3390.

Any additional thoughts?


Regards,
Chris

Collapse -

Problem Solved

by Kiurcher In reply to This information isn't co ...

Adding port to end of your IP works for the second PC after doing a REBOOT.

Changing port in Registry doesn't take effect till after you have restarted the PC.
Mental note for those inquiring.


Regards,
Chris

Back to Networks Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums