Windows

Question

Remote desktop services “termservice” is disabled intermittently on boot

By loganx1121 ·
I have a domain which has a virtual environment as well as several physical machines (mostly laptops). RDP is enabled via group policy. On the physical machines, never the virtuals oddly enough, I keep running into a problem where intermittently, the RDP service is disabled after a reboot.

I've ruled out a firewall issue. Those settings are pushed out with GPO as well. I also made a GPO to explicitly set the termservice to be "automatic" but that hasn't solved the problem either. Someone suggested that policy might be trying to applied before the physical machines have established a network connection, so I made a GPO to delay that using these instructions

https://docs.microsoft.com/en-us/troubleshoot/windows-client/group-policy/fail-to-apply-group-policy-at-startup

This also did not fix the problem. All of the physical machines are Windows 10 Enterprise and fully patched. There's one laptop I RDP to all the time, so I notice it the most there, but I've also noticed it on other physical machines. Sometimes I can reboot the laptop a dozen times, and RDP will work every time. Other times I can reboot over and over and RDP will fail.

When it fails, I enter-pssession to the laptop via powershell and I can see the termservice is stopped. If I physically go to the machine and look at the services, the startup type is set to disabled, but "Allow remote connections to this computer" is checked. I've checked the event viewer on the machine I see this the most on, and the only thing I can find is "'Failed CreateVirtualChannel call on this Connections Stack' in CUMRDPConnection::CreateVirtualChannel at 2622 err=[0x80070032]"

I'm at a complete loss as to why this is happening as this should be a simple and straight forward thing to achieve.

Any help would be greatly appreciated.
Thread display: Collapse - | Expand +

All Answers

Collapse -

Try this

by jessewalter375 In reply to Remote desktop services “ ...

Verify Remote Desktop is enabled
Start the System tool. To start the System tool, click Start > Control Panel > System Icon and then click OK.
Click the Remote tab. Under Remote Desktop, click the Enable Remote Desktop on this computer check box.
Verify Terminal Services Limit number of connections policy
Start the Group Policy snap-in, open the Local Security Policy or the appropriate Group Policy
Navigate to the location: Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Terminal Services Limit number of connections.
Click Enabled.
In the TS Maximum Connections allowed box, type the maximum number of connections you want to allow, and then click OK.
Verify Terminal Services RDP-Tcp properties and set via Terminal Services Configuration
Click Start, click Control Panel, double-click Administrative Tools, and then double-click **Terminal Services Configuration.
In the console tree, click Connections.
In the details pane, right-click the connection for which you want to specify a maximum number of sessions, and then click Properties.
On the Network Adapter tab, click Maximum connections, type the maximum number of sessions that can connect to the server, and then click Apply.

Collapse -

Ok

by loganx1121 In reply to Try this

I'll try it but I'm not sure how limiting the number of connections is going to stop the service from being disabled.

Related Discussions

Related Forums