• Creator
  • #2212723

    Remote Desktop


    by pentrex ·

    I set SOHO in our building : Lyncsis router, a printer and four PCs. I established the Remote Desktop connection with one of computers located in the other end of our building. Everything was fine. But when I tried to connect the Remote Desktop to my computer in my office from that remote one, I failed to do that.

    I checked all settings on both PCs Firewalls, settings in the router’s Firewall, checked both accounts have permissions to operate the Remote Desktop, but no matter what I tried I still cannot get the Remote Desktop connection from that computer. It works only in one direction. I use dynamic IP addressing in the router and double checked the addresses on both PCs.

    Anyone can explain what’s going on?

All Answers

  • Author
    • #2877158


      by pentrex ·

      In reply to Remote Desktop


    • #2877149

      Lets see if I’m reading this correctly

      by oh smeg ·

      In reply to Remote Desktop

      You are attempting to reach a computer through a Router at your end and at the other end right?

      If that’s the case you need to establish a VPN between the 2 routers. 😉


      • #2877129

        router only one

        by pentrex ·

        In reply to Lets see if I’m reading this correctly

        That’s right – reaching one computer at one end and from that end trying to reach the original computer and I can’t. But I have only one router.

        Btw ,I tried the Remote assistance and it works fine both ways, but not the Remote Desktop. Do I still need VPN? Or this connection is not possible with just one router?

        • #2877109

          RE: Do I still need VPN?

          by oh smeg ·

          In reply to router only one

          Not in that case.

          I’ll have a think on this and see what if anything I can come up with.


    • #2877124

      System versions?

      by tobif ·

      In reply to Remote Desktop

      What system versions do you have at both ends?
      (For example Windows Home versions don’t act as RDP servers, but can be a client)

      • #2877080

        XP professional

        by pentrex ·

        In reply to System versions?

        At both ends XP Professional. Suppose to work both ways but it doesn’t. But the Remote Assistance, btw having the same port 3389 as RDP, works fine.

    • #2877096

      Setting of Remote Desktop

      by -nhone- ·

      In reply to Remote Desktop

      In Windows XP Remote Desktop Connection is set to administrator with password.. try giving the user a permission to access remote desktop connection

      In Computer Properties – Remote Tab
      Allow user to connect remotely then select remote users. remote user must have password.

      • #2877078

        will check again

        by pentrex ·

        In reply to Setting of Remote Desktop

        Seems I tried this but will double check it again.

      • #2877055

        just checked

        by pentrex ·

        In reply to Setting of Remote Desktop

        Just checked in the Local Users and Groups console both accounts. Both are set to the administrative group. Both are members of the Remote Desktop Users. The Remote Tab in the System Properties certainly is checked otherwise I would have no connection in the first place. But the problem still remains the same- from the computer 1 to computer 2the RDP works OK, from the computer 2 to 1 it doesn’t. Message I got – “This computer can’t connect to the remote computer. Try connecting again”.

        Just unexplainable puzzle what else might be wrong here?

        • #2877011

          Sounds as if the Router isn’t letting you through

          by oh smeg ·

          In reply to just checked

          You may need to look at it’s configuration to fix this issue. 😉


        • #2876996

          Network Authentication

          by -nhone- ·

          In reply to just checked

          Sounds like you have network authentication in your computer 1 check your local network connection in computer 1 try to un-check Enable IEEE 802.1x authentication in Authentication Tab.

          windows xp sp3 with .net3.5 doesn’t work well in RDP try removing that if you ever install xp sp3 and .net3.5 that may cause the issue.

          and check terminal services for both computer if running in services console

        • #2878347

          will check that

          by pentrex ·

          In reply to Network Authentication

          That exactly what I have – XP sp3 .net3.5 sp1, and .net3.0 sp2 installed on both computers.

          I ‘ll check what you said.

          What exactly do I need to remove? .net3.5 or sp3?

        • #2878299

          Just the dotnet 3.5 version.

          by seanferd ·

          In reply to will check that

          No, don’t roll back sp3.

    • #2849089

      Backup and Try the Simple First

      by rkuhn040172 ·

      In reply to Remote Desktop

      Can you ping #1 from #2?

      Are you using the IP or computer name in RDC?

      Can you do a nslookup successfully? Tracert?

      Don’t skip the basics…you may find something obvious like a misconfiguration at the router/switch level.

      • #2848059

        Re: Backup and Try the Simple First

        by pentrex ·

        In reply to Backup and Try the Simple First

        I use IP in RDC

        Yes, I can ping from #1 to #2 and vice versa.

        There is no problems with tracert either from both ends.

        Nslookup gives the following output:

        ***Can’t find server name for address Non-existent domain
        ***Can’t find server name for address Non-existent domain
        ***Default servers are not available
        Server: Unknown
        Address: 192168.1.1
        ***Unknown can’t find Non-existent domain

        It’s the same output from both ends except the last line where address of the second PC is

        Is this looks like an error?

    • #2849087


      by ganesan.kuppusamy ·

      In reply to Remote Desktop

      Did u check the RDP port 3389, whether is opening or not. try doing
      telnet remotemachinename 3389 –> from the command prompt.

      • #2848058

        Re: RDP

        by pentrex ·

        In reply to RDP

        I checked the 3389 port by using the Remote Assistance. Works fine from both ends.

        Isn’t this enough?

        • #2847885

          Post your IP Configuration

          by -nhone- ·

          In reply to Re: RDP

          Say you have ip configured to static ex. mask gw for pc1 and mask gw for pc2

          try access to rdp.. if you have different gateway make a routing point from default gw to destination

Viewing 5 reply threads