Remote Desktop

By pentrex ·
I set SOHO in our building : Lyncsis router, a printer and four PCs. I established the Remote Desktop connection with one of computers located in the other end of our building. Everything was fine. But when I tried to connect the Remote Desktop to my computer in my office from that remote one, I failed to do that.

I checked all settings on both PCs Firewalls, settings in the router's Firewall, checked both accounts have permissions to operate the Remote Desktop, but no matter what I tried I still cannot get the Remote Desktop connection from that computer. It works only in one direction. I use dynamic IP addressing in the router and double checked the addresses on both PCs.

Anyone can explain what's going on?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Lets see if I'm reading this correctly

by OH Smeg Moderator In reply to Remote Desktop

You are attempting to reach a computer through a Router at your end and at the other end right?

If that's the case you need to establish a VPN between the 2 routers.


Collapse -

router only one

by pentrex In reply to Lets see if I'm reading t ...

That's right - reaching one computer at one end and from that end trying to reach the original computer and I can't. But I have only one router.

Btw ,I tried the Remote assistance and it works fine both ways, but not the Remote Desktop. Do I still need VPN? Or this connection is not possible with just one router?

Collapse -

RE: Do I still need VPN?

by OH Smeg Moderator In reply to router only one

Not in that case.

I'll have a think on this and see what if anything I can come up with.


Collapse -

System versions?

by TobiF In reply to Remote Desktop

What system versions do you have at both ends?
(For example Windows Home versions don't act as RDP servers, but can be a client)

Collapse -

XP professional

by pentrex In reply to System versions?

At both ends XP Professional. Suppose to work both ways but it doesn't. But the Remote Assistance, btw having the same port 3389 as RDP, works fine.

Collapse -

Setting of Remote Desktop

by -nhone- In reply to Remote Desktop

In Windows XP Remote Desktop Connection is set to administrator with password.. try giving the user a permission to access remote desktop connection

In Computer Properties - Remote Tab
Allow user to connect remotely then select remote users. remote user must have password.

Collapse -

will check again

by pentrex In reply to Setting of Remote Desktop

Seems I tried this but will double check it again.

Collapse -

just checked

by pentrex In reply to Setting of Remote Desktop

Just checked in the Local Users and Groups console both accounts. Both are set to the administrative group. Both are members of the Remote Desktop Users. The Remote Tab in the System Properties certainly is checked otherwise I would have no connection in the first place. But the problem still remains the same- from the computer 1 to computer 2the RDP works OK, from the computer 2 to 1 it doesn't. Message I got - "This computer can't connect to the remote computer. Try connecting again".

Just unexplainable puzzle what else might be wrong here?

Collapse -

Sounds as if the Router isn't letting you through

by OH Smeg Moderator In reply to just checked

You may need to look at it's configuration to fix this issue.


Collapse -

Network Authentication

by -nhone- In reply to just checked

Sounds like you have network authentication in your computer 1 check your local network connection in computer 1 try to un-check Enable IEEE 802.1x authentication in Authentication Tab.

windows xp sp3 with .net3.5 doesn't work well in RDP try removing that if you ever install xp sp3 and .net3.5 that may cause the issue.

and check terminal services for both computer if running in services console

Related Discussions

Related Forums