General discussion

Locked

Removing read-only attribute on N+ folder

By Skw5 ·
We have just moved onto a new Windows 2003 server we didn't upgrade. The share and ntfs permissions seem all okay. The issue is if I look at the properties of the root share the read only attribute is grey with a check in it. I am able to remove the check then it looks like it goes to all subfolders. Then I click the properties again and the check returns.
What could be happening?

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by BFilmFan In reply to Removing read-only attrib ...

That is default behavior. Ignore it.

Collapse -

by Skw5 In reply to Removing read-only attrib ...

...but I cannot make changes to files on the share.It prompts me to save a copy elsewhere in order to make changes.

Collapse -

by brudab In reply to Removing read-only attrib ...

The reason for this grey checkmark is that some folders within the root share are set as read only, while the others aren't.

My counter question is what exactly do you mean the root share? If it's one of the hard drives (i.e. C: or etc.) then I'd advise you create a subfolder and share that. NEVER share your root drive on a network. Too risky.

That aside, if the file(s) you want to edit aren't behaving, place them in a folder on the share and ensure that THAT folder isn't set to read only.

Collapse -

This is happening even on a standard share

by bro15360 In reply to

I have this same problem on a share I created under c The folder I created and all the subfolders have the same read-only attribute and I cannot remove it. All the MS documentation I can find says you can safely ignore this message but I can't ignore it when users can save changes to a share becuase it is marked read-only. Additionally, I have verified effective perms for the folder and the user that owns it has full access...but can't write to it. Crazy. Any other suggestions?

Collapse -

Same problem here cannot remove read only

by Elangford In reply to This is happening even on ...

I moved from an win 2000 server to an 2003 server. Having the same issues cannot remove read only attribute! I tred removing using command line per microsoft fix.. Still no luck if anyone finds an answer please notify me also..

Collapse -

all folders read-only

by shaghayegh.sahebi In reply to Removing read-only attrib ...

Hi,

I've got the same problem. All of my Win XP Home folders are read-only and I can't change the attribute right clicking the folder. I have no problem cutting the folders, but windows doesn't permit my C# codes to access the folders.

I have tried many solutions. Using attrib -r +s, changing registry value and setting admin permission for the user. I even tried "sfc /scannow" command and repaired my win XP using it's installation CD. I formatted and installed another win XP on another partition of my hard disk and the folders are still read-only on all partitions.

I don't want to format all my hard disk and install my win again ?ause I have to defend my thesis in a month and I don't wanna loose my installed programs and waste a day installing them again.

Please please help me. Thanks a lot in advance
--Chagh

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums