Question

Locked

Reset RDP session failed

By mhaffendi ·
Hello,
I am having problem with my Windows Storage Server 2003 R2. Currently there is one id (user A) that is logged in at the server console. The account has locked the console and I am unable to unlock it because when I press Ctrl - Alt - Del and nothing happens at the login screen. The weird thing is the
mouse is moving and I am able to press the NumLock key without any problem (this eliminate either the mouse or keyboard is not working).

To logoff user A, I remote desktop to the server and tried logging off user A using tsadmin. However I encounter error "Session (id 0) reset failed (error 31 - a device attached to the system is not functioning)". I tried to reset user A using Reset command also and that doesn't work. Anybody knows
how to solve this issue?

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

tsadmin will not work

by lowlands In reply to Reset RDP session failed

to log off the console session when the user is logged on to the physical computer console.

Can you try to log on to the console session by using mstsc /v:servername /console

That should allow you to log off the currently logged on user

Collapse -

mstsc /v:servername /console still not working

by mhaffendi In reply to tsadmin will not work

Hi lowlands,
I have tried the method but it seems not working. When I use mstsc /v:servername /console, I am able to see the login screen. After I enter my username & password, it prompted me whether I want to logoff the current user. Once I confirm yes, it shows as logging off the current user and closed my RDP session. When I tried RDP back, the previous user is still not logged off. Do you have any other suggestions?

Collapse -

I am afraid

by lowlands In reply to mstsc /v:servername /cons ...

that if that's the case a reboot is the only thing that'll help you get this users logged off. Something appears to be hanging.

One thing to try is to try the same procedure as above and wait until the user is fully logged off, and you are fully logged in. Also check the eventlog for any messages that might be related.

Collapse -

Terminal Services Manager

by Bizzo In reply to Reset RDP session failed

You could try going into Terminal Services Manager and seeing who is logged into the console on that machine. From there you should be able to either log off, disconnect, or reset that session.

Failing that, get the user who has this session open to log back on to the server and log off properly.

Or, if possible, go to the physical machine and log that user off.

Collapse -

Reboot server

by mhaffendi In reply to Terminal Services Manager

Hi Bizzo,

I have tried the steps that you mention earlier and it is not working. When the user tried to log off from console (physical machine), it is showing as logging off but after a while, it turned back to lock. Weird thing. Right now the only feasible thing that I could think of is reboot the server. Thanks anyway for your help guys.

Collapse -

experiencing same issue

by bloubert In reply to Reboot server

This issue seems to have started after we implimented RSA two factor authentication.

The only way to get the disconnected remote session cleared is a reboot; not a good solution on a production system!

Do you have some form of two factor authentication installed on the problem system?

Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums