General discussion

  • Creator
    Topic
  • #2259129

    rio8drv.sys Missing or Corrupt

    Locked

    by urxtradark ·

    I reformatted my Hard Drive using Ontrack Disc Wizard and Zeroed all sectors on the hard drive .I set up a partition on that hard drive
    and formatted that partition to NTFS and tried to install a copy of Windows XP Professional but the set up stuck at the level of copying
    Windows files to the hard drive and i got this message:
    ( rio8drv.sys ) is either missing or corrupt, If you are installing from a Windows CD, please insert the CD and hit Enter to try again
    , i tried numerous times but no signs of any progress, the status got stuck at 35% and eventually set up failed to install.

    Where can i find a copy of this ( rio8drv.sys )? Is it possible to patch this corrupt/missing file on the Windows CD?

All Comments

  • Author
    Replies
    • #3209154

      Reply To: rio8drv.sys Missing or Corrupt

      by wcp ·

      In reply to rio8drv.sys Missing or Corrupt

      Probable causes are CD, CD-ROM, or RAM(s), CPU fan, or CPU.

      1. CD ? Check for any visible scratch or other damages and try a replacement CD if found.

      2. CD-ROM ? Try a different CD-ROM

      3. RAM ? Do a RAM test and replace any if failed. http://tinyurl.com/7n63v http://tinyurl.com/buov

      4. CPU fan ? Make sure the CPU AND the fan got installed correctly.

      5. CPU ? If you still have the problem, replace the CPU.

    • #3209104

      Reply To: rio8drv.sys Missing or Corrupt

      by hal 9000 ·

      In reply to rio8drv.sys Missing or Corrupt

      It’s also possible that the Power Supply is failing and not producing enough regulated power. If you have a Volt Meter test the Voltages on one of the HDD connectors and make sure that you are getting the 12 & 5 V DC at the pins there.

      If this is an old system that was previously working I wold try changing the Data Lead to the CD ROM but if you have wiped it because of a problem it could very well be a hardware problem that is manifesting itself now though to be perfectly honest most XP installs hang at the 27% mark on a CAB file.

      A good way to rule out hardware failure is to boot from a Live Linux and see how the system works I personally prefer Knoppix but that’s me you could walk into a newsagent and buy piratically any Computer Mag with a Live Linux as a Cover CD and run from that to test the hardware. If this fails you can then use [b]The Ultimate Boot CD[/b] available here

      http://tinyurl.com/3jnpy

      To do some diagnostics. Of course if none of these work I would be looking at changing the CD ROM and the IDE Data Lead at the same time or with the price of DVD RW now days replace the CD with a DVD RW.

      Col

Viewing 1 reply thread