Question

Locked

Roaming Profile Issues

By HolmesWD40 ·
I am having some issues with roaming profiles that I haven't had any luck trying to fix. I have a few users that, whenever they delete a file from the desktop, it reappears at next login.

It's a windows 2003 server and each user is using windows xp. The my documents is redirected to the home directory that the roaming profile is stored in, and each user has full control on their home folder. A few users log into more than 1 computer at once, but there are many that don't log into any computer besides their own.

Any ideas on how to fix this would be awesome, thanks

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

See if this helps

by Jacky Howe In reply to Roaming Profile Issues

If a user has a roaming profile and logs on to different computers (locally cached profiles enabled), they may experience the following behavior:
<br><br>
After deleting files or folders on their profile and logging off from computer A, the files or folders reappear if they log on to computer B, where they have logged on before.
<br><br>
This problem occurs because the locally-cached profile on computer B still has the files and directories in the locally-cached profile. When downloading the roaming profile from the profile server, the user has a local profile with the former deleted files and folders again. After logging off from this computer, the complete profile is copied back and the former deletion of files and folders seemed to have no effect.
<br><br>
<br><br>
You will need to use these Policies to stop the use of the local profiles. :)
<br><br>
Using Group Policy to delete cached copies of roaming profiles
<br><br>
You can configure a Group Policy Object (GPO) to perform the preceding behavior by performing the following steps:
<br><br>
1. Edit the GPO that you want to modify.
<br><br>
2. Locate the following section: Computer Configuration \ Administrative Templates \ System \ User Profiles.
<br><br>
3. Double-click Delete cached copies of roaming profiles (the Group Policy setting).
<br><br>
4. Click Enabled.
<br><br>
Log users off when roaming profile fails.
<br><br>
<br><br>
GPO Computer Configuration, Administrative Templates, System, User Profiles
<br><br>
Logs a user off automatically when the system cannot load the user's roaming user profile.
<br><br>
This setting is used when the system cannot find the roaming user profile or the profile contains errors which prevent it from loading correctly.
<br><br>
If you disable this setting or do not configure it, when the roaming profile fails, the system loads a local copy of the roaming user profile, if one is available. Otherwise, the system loads the default user profile (stored in %Systemroot%\Documents and Settings\Default User).
<br><br>
<br><br>
<i>Keep us informed as to your progress if you require further assistance.</i>
<br><br>
<br><br>
<font size="1"><i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.</i></font>

Collapse -

Doesn't work

by HolmesWD40 In reply to See if this helps

I've tried that but the icons still keep coming back when the user logs off then back in. I'm not too sure what else to try with this, that's the only problem that happens, aside from one other having to reload the outlook mailbox each time he logs in.

Collapse -

See if this helps

by Jacky Howe In reply to Doesn't work

I always create a Folder on \ to put the Users Home Directories, Profiles and ClientApps. I like to keep the Profiles folder seperate from the Home Directory as it is a lot easier to manage. I normally have the Profiles Folder with a hidden Share EG: Profiles$. You could run XCACLs and give the Administrator and Users Full control of their Profiles Folder and see if it helps.

<br><br>
<i>Keep us informed as to your progress if you require further assistance.</i>
<br><br>
<br><br>
<font size="1"><i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.</i></font>

Collapse -

Profiles

by HolmesWD40 In reply to See if this helps

I think that's pretty much what we have going, except we have the profiles in the home directory. My manager has tried it having them separate for his but he still had troubles with things not saving

Collapse -

Check

by Jacky Howe In reply to Profiles

the User Account in Active Directory and make sure that the Profile is pointing to the right Folder and check the Home Directory path. Also check the permissions on the Profile Folder.
<br><br>
< edit>
<br><br>
The User and the Administrator should have full control.
<br><br>
<i>Keep us informed as to your progress if you require further assistance.</i>
<br><br>
<br><br>
<font size="1"><i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.</i></font>

Collapse -

Fixed it

by HolmesWD40 In reply to Check

Figured it out, after some searching I came across something at microsoft about certain nvidia drivers having issues with roaming profiles loading 2 profiles or something, installed the latest drivers and they seem to be working now, thanks for your guys' help

Collapse -

nVidia strikes again

by Jacky Howe In reply to Fixed it

Glad that you got it sorted out.

Collapse -

Check the storage folder

by LarryD4 In reply to Roaming Profile Issues

Does the user have the correct rights to delete items out of their desktop folder in the storage location?

AD automatically sets the correct rights for a users home folder directory but you may want to check the desktop folder rights thats one level up from "My Documents" in the profile storage location.

Collapse -

Folder rights

by HolmesWD40 In reply to Check the storage folder

The users have the correct rights to each folder above the My Documents folder, they all have full control

Collapse -

Assumptions I have made

by Kenone In reply to Roaming Profile Issues

I assume you don't have "Mandatory Profiles" set.
I assume the item that they are trying to delete is actually in their profile and not in any other eg: All Users.

Correct?

Back to Networks Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums